Domain!


#1

Hello.

I am so far happy new customer since yesterday! Everything went ok and fast. But i have two questions.

  1. Who is the owner of the domain i regged through dreamhost. If i whois this domain it only says dreamhost. Could somebody explain this?

  2. Where is the cgi-bin dir on my ftp? I would like to install some scripts that uses cgi-files. How should i solve this?

Thx for the time and reply.

IJSCO


#2
  1. It’s yours. If you chose private registration, it will show DH’s info… but it’s yours.

  2. You can run scripts from anywhere–no need for a cgi-bin directory.


:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.


#3

Thx for your reply.

But the cgi scripts are still bothering me. I have created my own dir and uploaded all cgi scripts. Now i am trying to call the init.cgi (installation script) and it giving me a 500 error

What is going wrong here? Do i need to turn cgi scripts on in the control panel something like that?

your time is much appreciated


#4

You might start with the “usual suspects”:

Were the scripts uploaded in ASCII mod?

Have you made sure you have your shebang set properly for the application, and have you set the permissions on the script(s) to 755?

What do your error logs say?

–rlparker


#5

i assume all script are uploaded ascii since this is taking care by my ftp prog.

The shebang i used now is: /home/user/mydomain.com/cgi-bin/admin/.htpasswd

changed that user and mydomain.com ofcourse!
my scripts are located in cgi-bin i added myselff

thx


#6

ok i figured it out! i was missing 755 chmod.

thx for your time!


#7

Good Deal, and you are welcome! I’m glad you got it working. :slight_smile:

–rlparker


#8

well i have one more thing :smiley:

Is that shebang correct?


#9

“Shebang” refers to the first line of your script, which will often look like this:

#!/bin/bash #!/usr/bin/perl It’s sometimes called the “shebang” line after the first two characters – #! – which are sometimes called “hash” and “bang”, respectively (get it?). This line contains the path to the interpreter used to execute the script contents.

The path you posted could be used by HTTP authentication in an .htaccess file. It has nothing to do with the script you’re running, except that it may control access to it.


If you want useful replies, ask smart questions.


#10

Not really…at least it is not a shebang line at all (in this sense I was referring to it - see the linked article). The shebang line is the first line of a script that identifies the program to execute the script.

The line you provided above appears to be a path from a configuration section of the script - without seeing the script and/or knowing what it does (or what is asked for) I don’t know if it is “correct” for the script or not.

That accurately describes the full path to the .htpasswd file in the admin directory of your domain’s cgi-bin directory. I have no way of knowing if that is what it should be or not-that depends on what your script is looking for. :wink: .

If you can’t figure it out, it would help others help you if you provide a url to the script/instructions you are using so we could look at it.

–rlparker


#11

readme is saying!

This is a sample .htaccess file. You will need to change the AuthUserFile

directive above so that it points to the location of the .htpasswd file

in the admin directory. The .htpasswd file will be created by the init.cgi

script, so the part you need to change is /home/soft/cgi-bin/agp/admin

Example:

If the full path to your admin directory is /home/username/cgi-bin/arp/admin

Then the above line should look like the following:

AuthUserFile /home/username/cgi-bin/arp/admin/.htpasswd

so i used /home/user/mydomain.com/cgi-bin/admin/.htpasswd

error message i get is Checking .htaccess file for proper AuthUserFile setting Failed
Directory Not Found

extra info with it
.htaccess AuthUserFile setting test

This test will check to make sure that the AuthUserFile setting in the .htaccess file points to a valid directory on your server. If this test fails, it indicates that you have not setup the correct full path to your admin directory. Check for typos in the directory setting, and if necessary contact your server administrator to verify you are using the correct path.

so what is wrong with my path?


#12

The snippet helps, but without seeing the whole thing it’s hard to know for sure what might be causing the problem.

Is it possible the init.cgi script could not create the .htpasswd file, or the admin directory in the directory because of permissions? Since DH runs under suExec, you should make sure your cgi-bin and cgi-bin/admin directories are set to 755 also - even if the instructions with the script say differently.

Again, what script are you trying to install?

–rlparker


#13

i am trying to install autogallery pro 2.1.1 I am sure i set everything on 755

Is it possible for you to join the chat here?


#14

I’m sorry, I’m checking the forum on occasion wile doing other work, and am not available for chat.

autogallery pro 2.1.1 is a commercial program - have you checked with the author for support on installation?

–rlparker