Domain shutdown Phpbb


#1

Have been running my forum now for over 2 months and have just received this from hosters:

It appears that your site is currently using a large amount of CPU timeon the server you are hosted on (named “mug”). Currently there are three php.cgi processes each using 30% of the CPU, and it is making the load averages on the server to go up.
I have had to disable your site because it is making the load averages on the server to stay up between 15.00 and 25.00. This is unacceptable.

The site has been using these scripts since intialisation and things have been running well till recently…so am at a loss here as to what needs to be done to rectify and satisfy dreamhost: Have checked the log files and all the errors of some sort refer to missing files:

internal_error.html
missing.html
File does not exist:

Not being fully familiar is there anyone here who can direct me on to sort this problem out.

Would really appreciate any help…thanks


#2

You’re not looking for errors.

You’re looking for what is causing the script to take a long time to process or gets stuck, causing the server to “concentrate” too hard on your script.

In other words, a script is like a recipe for cooking. The longer the script is, the more time it may take to get done. Even then, certain steps will take longer than other steps: searching a database or resizing an image will obviously take more time than formatting HTML output.

If the scripts access a database you may need to add indexes to the tables.

Analyze the HTTP access log file for exactly what URLs are being hit. That way you know what scripts are being used and can see what they are doing so you can figure out which ones are taking too long.

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#3

Virtually all the errors in logs files refer to files that do not exist…? or a Premature end of script headers: php.cgi.

The phpbb board being used is a fully modded one total 456 mods which was installed complete not all mods are being used as a lot were disabled as not being used…the board was running fine until recently and all we got was 503 errors…the features added are separate divisions so do not affect main forum…although linked they have individual site adresses.

Will check on MySql database see if it has been optimised or not.


#4

Handler_read_rnd 35 k

The number of requests to read a row based on a fixed position. This is high if you are doing a lot of queries that require sorting of the result. You probably have a lot of queries that require MySQL to scan whole tables or you have joins that don’t use keys properly.

Handler_read_rnd_next 8 M

The number of requests to read the next row in the data file. This is high if you are doing a lot of table scans. Generally this suggests that your tables are not properly indexed or that your queries are not written to take advantage of the indexes you have.

Slow_queries 5 k

The number of queries that have taken more than long_query_time seconds. MySQL - Documentation

All these are in the red within mysql does this signify some changes need to be made to offset the problems…?


#5

Be careful - you may be looking at the stats for the entire mysql server and not all of those requests are yours.

Wholly - IS NOT MY PROMO CODE. Even worse, I don’t get any credit for it. Use WhollyMindless for full credit. I’m really disappointed in someone.


#6

Thanks for that info on Sql…am about to throw all system through window…lol :slight_smile:


#7

Most likely, it’s one of your MODs. Some of them can be quite resource-intensive: Are you running the birthday MOD, by chance? Honestly, I would recommend a fresh reinstall, but that might involve a good bit of work to clean things up if the MODs have made database changes.

emufarmers.com
Very little to do with either emus or farmers!