Domain refuses to host?


I’m new here, and have a mystery. All of my domains have transferred successfully to dreamhost save one., which I use simply as a redirect to, will not set up in hosting, either as fully hosted or as a redirect. The error I get is pasted below:

You can’t add that domain: you don’t have permission to add

The domain is currently registered at godaddy (I will tranfer most of my domains here as they expire), and I cannot see any difference on that end between that domain and others that have hosted successfully. As of yesterday, the domain is not hosted at all, since my previous host has already finalized my contract.
Have I missed something at godaddy? Have I missed something here?
It’s not the end of the world, since I can have it forwarded on godaddy’s end; I just have trouble leaving a mystery unsolved, and I’d like to have everything in one place (eventually).

Things I’ve tried here:
Full hosting, default settings
domain redirect
logout/login to DH account
Wait 24 hours+ for DNS to propagate
(same error msg in each instance)

Things I’ve tried at godaddy(& current relevant settings):
ownership protection:off
lock status:unlocked (for the brief moment - everything else transferred w/o needing to be unlocked)

Thanks in advance,


Can you add another domain? Try something really out there like
If that doesn’t work, then I’d say that your account doesn’t have permission to set up Hosting. Are you the owner of your paid hosting plan here?

#3 is already on another customer’s account here. It looks as though they closed their account many years ago, so Support should be able to remove the domain from their account for you if you ask.


Andrew, doesn’t the error usually say that it’s “already in the system”?


Hi guys,

Thanks for your prompt replies. Yes, all the other domains have hosted fine, including I’ve owned the domain for a dozen years or more, and this is only the second time I moved it, but it’s possible that the original host was a dreamhost affiliate. I’ve poked around a bit, but haven’t found an easy way to open a support ticket - I keep getting shunted into the wiki, which under most circumstances is great, but it seems I need some direct help here. Any pointers?

Thanks again,
duh-rrr found it!! It’s always the obvious ones that get away from me. off to post a ticket. thx. K