Domain redirecting question?


#1

At least I think its a domain redirect question. I have uploaded drupal and got it working on Dreamhost servers thanks to much help from members of this forum! Now that its up I have another question. My site is located at www.mysite.com/drupal, and I want it to be located at www.mysite.com without having to type the /drupal. Now I assumed this was a case of simple domain redirection. Now my domains are with Go Daddy, so I went over there and redirected www.mysite.com/drupal to www.mysite.com, however nothing happened. You still need to add the /drupal to get to my site.

Is there something on my Dreamhost server side I need to change to fix this?

THanks


#2

You’re hosted here. I would suspect that changing anything at GoDaddy isn’t going to do anything but knock you off the net.

Go to your control panel and under “Manage Domains” and point that at the directory “/home/user/www.mydomain.com/drupal”

That should work like a treat. Of course if it doesn’t someone will come along and straighten me out.

Wholly


#3

Thank you very much for the reply but I’m still confused. I’m kinda new to all of this having only used free hosts that arrange your domain for you. So I went to manage my domains, but I have no idea where home/user is exactly?

I kind of need a step by step/link by link walk through. I know I’m asking a lot of questions, but I’m still learning all this.


#4

I’ve never tried wholly’s suggestion of changing the domain directory, but here are the steps to attempt his fix:

  1. Go to https://panel.dreamhost.com
  2. Click on Domains on the left
  3. Click on Manage Domains in the menu that drops down
  4. Click “Edit” next to your Fully Hosted domain name
  5. Change the Web Directory to be yourdomain.com/drupal
  6. Click the submit button (“Change fully hosted settings now!”)

But I’ve gotta ask - why don’t you move your Drupal installation into your domain directory instead having it in a drupal directory?

It’s quite possible that by resetting your Web Directory that it’ll break your site because the Drupal config probably says it’s in http://www.yourdomain.dom/drupal, which will no longer be found.

The right way to do this is to move everything up into your domain directory and then edit the Drupal config file for the correct paths.

-Scott


#5

Thanks, I actually do have my drupal folder in my domain directory. There is a folder on my server with the name of my website.com, so I put drupal in that folder. Unless you mean that I should have taken the contents of the drupal folder out and just installed the contents directly to my domain folder?


#6

I think that is what Scott is suggesting. Remember to modify any file paths in the Drupal configuration file(s) for the new location.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#7

OK I did it (moved the files up), and my site is screwed up as expected. So does anyone know exactly what files I need to edit and where? As I have no clue.


#8

I also suppose I could re-upload the site as it had very little content on it. But it would be nice to know how to fix it just in case I need to do it in the future.


#9

Hi again! It sounds as though you might be running into problems with either your drupal config file (path now needs to be changed from something similar to “/home/.something/yourusername/yourdomainname/drupal” to something similar to “/home/.something/yourusername/yourdomainname” to reflect the change you made) or your .htaccess re-write rules (because you have changed the location of the files whose urls are going to be re-written).

It would help a lot if you could provide a url to your site so we can see what is happening :wink:

–rlparker


#10

Here’s my site http://www.thesheepspen.com/

That’s what happened after I moved it. It’s basically full of joke filler content as I was simply testing it out, so like I said, no big loss here, but it would be nice to know how to repair for the future.


#11

Thanks for the link - actually, even though it looks pretty scary, your site is only *very slightly" borked - your config path’s are now wrong and Drupal cannot properly load you stylesheet(s) and your url’s are misformed.

The best way to troublehsoot this ti to inspect the source of your pages (use view source in your browser) and not how the links are formed by drupal vs how they need to be formed.

For instance, n your current setup, when a page is generated by Drupal and displayed, you see in your source several attempts to load style sheet files thusly:

[quote]@import “//misc/drupal.css”;

@import "//themes/andreas01/andreas01.css"; @import "//themes/andreas01/andreas01.css"; @import "//themes/andreas01/print.css"; @import "//themes/andreas01/style.css"; [/quote]

These files are not loaded, because they are not found - and this is because of the setting in the config file and/or Apache re-write rules at play.

The files are there (just check out http://www.thesheepspen.com/themes/andreas01/style.css), but Drupal is not searching for them correctly because the path to them has “changed” from when you installed it.

To fix this, you need to edit your config file and change the paths that were correct for your previously installed location (in a subdirectory of thesheepspen.com - thesheepspen.com/drupal) to properly reflect the new location of being in thesheepspens.com (thesheepspen.com).

–rlparker