Domain Points to Wrong Host?


#1

I am working on a client project, and both their domain and website are hosted through DreamHost. Initially, I let them set things up, and they chose the option to add the “www” to the beginning of the domain because they thought it was required.

I built a static HTML placeholder page and FTPed it to the server, but wasn’t able to view the page over HTTP. The site kept asking me for my login credentials and referenced “me.com.”

I poked around and found a random CNAME entry for “web.me.com” that my client probably put in by mistake. I removed this, but it didn’t really fix anything, even after waiting several hours for the changes to propagate.

I tried pinging the server, both with and without the www … this is where the real weirdness sets in.

Without the www, the ping works as expected and returns my client’s server IP. With the www, the ping claims it’s communicating with e292.c.akamaiedge.net. Since the server was redirecting everything to the www version, I switched the settings around (telling the server to strip the www) and now can see the site as I expect.

But what is causing the strange behavior here? A ping to launchretailstrategies.com works, but a ping to www.launchretailstrategies.com does not work and breaks the site. What can I change from my end to correct this?


#2

Sounds like your computer (or ISP) is holding on to some old DNS data. Everything works fine for me, so it’ll probably work fine for you by sometime later today, or sooner if you flush your DNS.


#3

Actually, I always flush before I ping just to make sure. But it looks like my machine was pulling its DNS from another server that just hadn’t updated the way I’d expected. It was annoying to have to wait 5 hours to get things to work, though (particularly since one form of the domain worked immediately but not the other).