Domain Not Resolving With WWW Before It?


#1

Hey everybody,

This might be something that I should know already, but I registered a domain and got hosting space with DreamHost, and when I enter the address without the “www.” before it, it works fine, but with the “www.” before it, it doesn’t resolve.

Is that a permanent thing? I always assumed that anything that worked as http://x.com also worked as http://www.x.com.


#2

How long ago was the domain setup? I have seen the same thing on newly added domains while the DNS information was still propagating across the Internet.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#3

It was just registered last Thursday, but it’s resolving without the www, so I was a bit confused. You think it’ll start working with the www soon as the DNS info continues to propagate?


#4

Was it also added to the DreamHost hosting system last Thursday? If so, the DNS information should have had plenty of time to propagate, it normally takes less than 72 hours to fully propagate.

You can check if the www DNS record for your domain has been created correctly by going to Domains -> Manage Domains in the panel, clicking the small [DNS] link next to your domain and looking for the presence of a A-Record named www in the Non-editable DreamHost DNS records section.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#5

If I understand you correctly, it works when you type http://domain.com, but not http://www.domain.com

The default setting for “how would like the www in your url?” should be “Both http://www.domain.com/ and http://domain.com/ work.”

You can always check the setting in DH panel --> Domains --> Manage Domains --> Edit Web Hosting

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].


#6

None of the 3 options available for that panel setting would result in the behavior the original poster is seeing, www.x.com not resolving, while x.com does resolve.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#7

the same thing happens to my domain. http://domain.com works. http://www.domain.com is not resolved. in the panel i selected both www.domain.com and http://domain.com should work. but still http://www.domain.com is not working.


#8

Is this a domain that has been recently (less than 72 hours) added to the DreamHost system?

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#9

yes ofcourse. its been added less than 72 hours ago.

it was the there before. but just a few hours back i installed phpbb in it using dh’s 1 click install.

before that nothing was installed in the domain.


#10

Then the problem is likely to be caused by the DNS information not having fully propagated across the Internet yet. In my experience, it is not uncommon for such problems to ‘come and go’ while the DNS information is propagating.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#11

As far as I can tell, everything was initiated last Thursday - I started uploading files, and I got an email saying that the domain name had registered. I looked in my Control Panel, and I do see an A entry for www, and I also have it set to both in “How do you like the www in your URL?”

I guess I’ll wait a bit longer and see if it resolves itself :slight_smile:


#12

Like I said above, I would have thought that sufficient time had passed for your domains DNS info to have fully propagated by now. If www doesn’t begin resolving for you within a couple of days, I would suggest lodging a support request detailing the problem, there may have been a ‘glitch’ in the system somewhere.

Another thing that comes to mind, make sure you clear any DNS cache that might be active. If you are using Windows, enter the following command at the command prompt to clear the Windows DNS cache.

ipconfig /flushdns

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)