Dokuwiki

apps

#1

Has anyone tried to install dokuwiki on dreamhost?
I’m getting error: metadir does not exist or isn’t writable. Check config!

How do I change the permissions to rwxrwx— or 770 for the
dokuwiki/data/ directory and all files and directories below?

Thanks


#2

dokuwiki on dreamhost …

First, I’ve not installed and run dokuwiki on Dreamhost.
That said, I have installed and run dokuwiki on my localhost (a Win2K, SP4, with XAMPP).

I had the exact same symptoms.
The answer is to manually create the referenced directories and set permissions to u+rw, g+r-w, o+r-w … command syntax is suggestive only …

Setting permissions.
Open a shell window.
issue the command: man chmod
read the fine print.

Don’t wanna mess with the fine points of Linux?
Use a Windows FTP client that lets you set permissions, such as FileZilla (available, free, at sourceforge.net).

HTH.


#3

You can change your permissions either via the chmod command from the *nix command line (log in to your account via ssh/telnet), or (my choice!) via most ftp clients.

I use (and love) leechftp - just google for it, it is free.

While I have not yet installed docuwiki on DH, I strongly suspect that, in spite of install instructions to the contrary, on DH you want to set those “writable” directory’s permissions to 755, not 770 as instructed. Assuming you are running PHP as CGI (which most users are, at present), PHP runs as your user, so 755 permissions will be sufficient, and DH often gags at setting looser permissions.

I plan to do a docuwiki test install later this week, I’m just too busy at the moment to try it now, so let us know whether or not you get this worked out. If not, I’ll report back what I discover when I do my test install.

Good Luck!
–rlparker


#4

I’ve just installed the latest Dokuwiki version on Dreamhost and got it to work. It took a bit of tinkering. Re file permissions: you do not have to make files in the Dokuwiki install directly group-writable. The default permissions should be okay.

If you want to use DokuWiki’s rewrite feature (turns URLs into something that is more human-readable), you need to configure (in conf/local.php) userewrite=1, and then edit the .htaccess file in the DokuWiki install directory to uncomment the Rewrite lines. I first tried using the built-in DokuWiki rewrite (userewrite=2), but it breaks because of DreamHost’s PHP installation (because PHP is run as a CGI program rather than an Apache module).

I’d be happy to try to answer questions from people having problems getting DokuWiki to work on Dreamhost.