Does Moodle 2.x work with Dreamhost yet?

apps

#1

Hello everybody,

I’ve been over every way that I found to install Moodle 2.0 and up (Current stable version 2.7+). I’ve attempting to install since I’ve been a customer of Dreamhost, October 2013, and have yet to successfully get it working. I have been over this with support as well, I can post my support log, my custom phprc, and anything else if it will help.

Moodle 1.9.19+, which by the way has been discontinued little over a year now, works fine. Although I cannot install another instance of Moodle 1.9.19+ using the One-Click Install feature anymore. Moodle 2.3.11 is no longer supported by Moodle either. (Source: http://download.moodle.org/)

Is there a plan to move Moodle to more current, stable, and secure version? Can anyone guarantee that Moodle 2.x will work with VPS or a dedicated server? My Moodle site will only have 20 active users at any given time. We don’t intend to allow more then that for contract reasons with our clients.

Could this be a MySQL issue and can there be something wrong with my MySQL server? I notice during the creation of the tables for the database during the install that it times out. I’ve tried to fix this with support suggestion with a custom phprc.

My phprc:

upload_max_filesize = 20M
post_max_size = 20M
max_execution_time = 500 (<- I’ve gone as far as 3000 which does not have any effect.)
max_input_time = 500 (<- I’ve gone as far as 3000 which does not have any effect.)
memory_limit = 128M
extension = intl.so
display_errors = off

I’m willing and able to do anything at this point, VPS, multiple dedicated servers (although if I need that for 20 users, I’ll be wondering why and expecting an answer before money changes hands). If I move to VPS or a dedicated solutions and Moodle 2.x will not work on these solutions, how hard will it be to downgrade my service back to shared hosting? Will there be any downtime and how much?


#2

I have gotten Moodle 2.4 to work on Dreamhost. It was a pain, and it took several attempts, but I did manage it. It was neither easy nor fun.

I later tried to upgrade to 2.6, and hosed the entire thing. I still work on it off and on, but have yet to come up with a solution.

I believe that’s fairly easy to accomplish. Shouldn’t be any more downtime than was involved in upgrading to a VPS.


#3

So far the only way that I was able to get Moodle 2.7 installed was install an instance onto my local server in my office (The server is setup as close as I can get to the Dreamhost setup). I then setup Dreamhost with the same settings as my local server, (MySQL Database and all) and backed up the database from my office server and then restored the database to the Dreamhost server.

Seemed to work, although I didn’t know how stable it would be for users and courses.


#4

@legacy:

How did you get the Moodle files themselves on your server? Via FTP or via the shell?


#5

And now Moodle 1.9 is not even available as a one-click install. Maybe a 2.x one-click is in the works?


#6

Anybody who needs help with this. Dreamhost Support has given me the solution to installing Moodle 2+ on shared hosting! This is not an alternative from using Dreamhost’s VPS hosting for your Moodle.

At this time and date Dreamhost does not support Moodle 2.7 as it requires PHP 5.4.4, at least not on Shared Hosting.

Here is the solution I have working right now.

Used settings in this thread from Deliot, thanks by the way! Although I’m not sure if it is needed, I have not removed the phprc file to see if it works or not.

And after emailing support, here is what worked. Changed my PHP version/settings from FastCGI to CGI.

“The trouble might be due to the install timing out because of the FastCGI timeout. Maybe try switching to PHP 5.4.x CGI in the Domains > Manage Domains section. FastCGI has a shorter timeout setting than CGI.” - Thanks goes to Kacy S for this one!

Thanks to everyone that commented on this issue and I hope this helps someone else.


#7

And can you switch back to FastCGI afterward? Or do you have to stick with plain old CGI?


#8

That I am not sure of. I believe that you only need to disable FastCGI to parse/run the functions necessary to build the database during setup. That seems to be the point that fails/times-out during setup with FastCGI as far as I can tell.

Part of me thinks, though, that if you need to disable FastCGI in order to parse/run the functions necessary to build the database during setup, then you would still need CGI run normal Moodle 2 functions, since it is really posting and pulling from the database…not sure if that is the right way of thinking about it though.


#9

You should be able to turn FastCGI back on once you’ve completed the install process.

The reason it’s necessary for the installation is because some steps of the Moodle installer can take a very long time to complete; in some cases, this may exceed 30 seconds, at which point FastCGI gives up and sends back an error message indicating that it timed out (usually 503 “gateway unavailable”). CGI has longer timeouts, which will usually allow the installer to finish up properly. Once you’ve got the database set up, though, nothing you do in Moodle should take that long to complete, so FastCGI will work just fine.

(Edit: The same thing goes for other applications as well. It’s not specific to Moodle.)


#10

Thank you very much for the reply! I will happily turn my FastCGI back on. :slight_smile: