Does anyone know anything about FFmpeg?

apps

#1

I used this wiki tutorial (http://wiki.dreamhost.com/index.php/FFmpeg) to install FFmpeg on my server but I can’t find the path to the directory after I did it… either I deleted it or I didn’t use the correct path when I installed it. Should I have substituted something for $HOME like my own personal paths or was I supposed to used $HOME? Here are the instructions:

Login to SSH as the owner account of your directory
If ~/bin doesn’t already exist, enter “mkdir bin” to create it
Enter “chmod 775 bin” to set the correct permissions for the bin directory
If ~/lib doesn’t already exist, enter “mkdir lib” to create it
Enter “chmod 775 lib” to set the correct permissions for the bin directory
Enter “svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg” to download the ffmpeg program source
Enter “cd ffmpeg” to navigate to the source directory
Enter "./configure --prefix=$HOME --cross-compile"
Enter "make"
Enter "make install"
Enter “cd …” to exit the ffmpeg directory
Enter “rm -rf ffmpeg” to delete the directory and clean up after your compilation
If no errors occur, FFmpeg should now be installed in ${HOME}/bin with supporting libraries in ${HOME}/lib.

I can’t find the directory in hom/bin or usr/bin and I don’t have a /bin in my own personal directory. Any help would be greatly appreciated.


#2

If you didn’t get any errors when you were compiling ffmpeg there should be two directories for you to find. You were correct in using $home. That’s just a shortcut to writing /home/username/ (and having each person have to update the script). So, if things went correctly you should find those two directores in your home directory - that’s where you are when you first log in to ssh or FTP.

If they’re not there, you probably had a fatal error during the process and it didn’t really install. Try again and watch for the error this time so you can trouble shoot.

–Matttail
art.googlies.net - personal website


#3

thanks for the reply. I think it installed OK. There were no fatal errors that stopped process anyway. I didn’t know if that last command deleted the directory or just the install files. Can you tell me the path they should be in? Is it /home/username/bin?


#4

I recently did the same thing for a gallery site, and it worked fine. I have bin & lib directories in my home directory.


Alec Usticke
alec@usticke.org
www.usticke.org
DreamHost referral


#5

yeah, the last step in the script deletes the FFMPG folder where it downloaded the files and uncompressed and such. Stuff you don’t need any more once it’s compiled.

The two folders should be in your home directory. by the server that is /home/username/bin. You’re placed into your home directory when you first log in via FTP or SSH. So log into the server and look at a listing of your files/folders. “ls” though SSH. Do you see the folders there?

–Matttail
art.googlies.net - personal website


#6

I think I know what I did - i created a new username just for SSH and I probably should have used the default username for the account… I would think that would have the same effect but obviously not. I just restared the process and already it’s working - I know have both the bin and lib directories in my home directory… I guess you can’t log into SSH with anything but default username.

Edit*
"I got it working but now my video uploads say “Error resizing image/ creating thumbnail.” Is there anything I need to do in order to get FFmpeg working or should it work just by using the correct path?


#7

Yes, you’re correct - only one SSH user per domain. Users are the same whether they’re FTP or FTP with SSH, only one for a domain and any others you create will have their own non-web acceccable space enless they’re the owner of a domian. So yeah, you have to log in with the user for that domain if that’s where you want the files.

As far as using FFMPEG you’ll have to point what ever you’re doing to the appropiate place. You’ll want to update your path. The OS isn’t magicailly going to know that you’ve got this program - you’ll have to point it there.
log into SSH
type “nano -w .bashrc” and press enter
add this on it’s own line after anything that’s already there:
PATH=$HOME/bin/:$PATH
press ctrl-o to save, press enter to accecpt the same file name, and press ctrl-x to exit. this should get it working for a website script. Add the same line to .bash_profile for use from shell. It may be that you need to add in your lib directory if things arnt working yet, just edit the above file again and add in lib:
PATH=$HOME/bin/:$HOME/lib/:$PATH

–Matttail
art.googlies.net - personal website


#8

thanks for all the help, but that didn’t work either - same error. I read on another forum for this Gallery (Zoom Gallery for Joomla) you need to have LAME installed before you install FFmpeg, know anything about that?


#9

when you run ./configure an error should be given if it depends on lame.

You can also try running ./configure --help to see if you can include lame. If you can you need to install lame first ofcourse.

BTW: be carefull with using ffmpeg from scripts since you could introduce high cpu usage very easy.

Use coupon: “THECIPHER” for a $97 discount


#10

I’m just using it to create thumbnails for videos in my Gallery… there will be very few videos. I’m pointing to ffmpeg but it’s not working. What’s the command I can use in SSH to test thumnail creation?


#11

Fixed it - wasn’t FFmpeg after all. The Gallery I’m using was using ‘sinlgejpg’ as the command for thumbnail creation, but all the new versions of FFmpeg use ‘mjpg’ as the command. Once I changed that in the code it all worked fine. Thanks for the help guys.