Do-release-upgrade (tmp/noexec)



First, let me say that I’m doing the following in sudo -s mode, so the fact that I’m leaving out sudo isn’t the problem.

I tried to run do-release-upgrade, but it says, “Can not run the upgrade. This usually is caused by a system where /tmp is mounted noexec. Please remount without noexec and run the upgrade again.” The Ubuntu forums say to edit /tmp in /etc/fstab, but that file says:

This file is not used on vserver guests.

Check /etc/vservers/ps461825/fstab on iad1-vshost47

I tried mount -o remount exec -t tmpfs /tmp, but it told me that permission was denied. I tried to unmount /tmp, but it told me that access was denied.

How can I upgrade my Ubuntu release?


Don’t do that. Our management tools depend on a number of package that we’ve currently only built and qualified for Ubuntu 12.04. Upgrading to another release will break most of the management features in the panel, and may cause your VPS to fail to boot properly.

If you want an unmanaged system with a current version of Ubuntu, set up an instance in DreamCompute.


So with this VPS I am stuck on 12.04 forever? When you’re ready to support 14.04 will I need to build a new VPS from scratch?


I can’t say for sure, since we haven’t gotten there yet, but generally speaking: So long as you haven’t made any customizations to your VPS using an admin user, we can (and will) upgrade your VPS to newer OS releases as they becomes available.