DO Clone using BackupBuddy shows Broken CTP URsl on DreamPress


#1

I just cloned an upgraded version of imagewize.com from Digital Ocean’s Droplet (Ubuntu 14.0.4 LTS, MySQL Server version: 5.5.38-0ubuntu0.14.04.1 (Ubuntu)
with PHP 5.6.0-1+deb.sury.org~trusty+1 (cli) ) to my DreamPress account. Before I moved I wiped out the database at DreamPress as well as all data. Now I see a homepage with the portfolio menus not loading portfolio as a link nor the sub menu items as portfolio/web-development or portfolio/web-design as I do on Digital Ocean. The Backbuddy went smoothly although the initial run ran into a Varnish 503 error the second run was just fine. Only now the portfolio urls for which we just did some Custom Post Type voodoo to make it work with the urls and items/categories as needed do not. They - portfolio main page, portfolio category pages - lead to 404s like:

Accept-Ranges bytes Age 0 Cache-Control no-cache, must-revalidate, max-age=0 Connection keep-alive Content-Encoding gzip Content-Length 3773 Content-Type text/html; charset=UTF-8 Date Mon, 29 Sep 2014 06:27:39 GMT Expires Wed, 11 Jan 1984 05:00:00 GMT Pragma no-cache Server Apache Set-Cookie _icl_current_language=en; expires=Tue, 30-Sep-2014 06:27:37 GMT; path=/ wpsession=1; expires=Tue, 29-Sep-2015 06:27:38 GMT; path=/ Vary Accept-Encoding Via 1.1 varnish X-Cacheable NO:Not Cacheable X-Pingback http://imagewize.com/xmlrpc.php X-Varnish 181394587

I purged Varnish Cache many times as I did MaxCDN Cache, but the menu keeps on loading the portfolio categories as uncategorized category and all the portfolio pages lead to 404s.

Could someone tell me why this could possibly happen? Do move my site to Digital Ocean to make this all work seems rather radical…

P.S. It ran well locally using PHP 5.5. as well.


#2

Did get portfolio to work now. Somehow one plugin - WordPress Post Type Archive Links- got deactivated during installation which is odd. The portfolio url starting working after about an hour. On saving the permalinks again and then the menu to see if I could make the Custom Post Type Categories work I got another lovely Varnish Caching error
Error 503 Service Unavailable
Service Unavailable
Guru Meditation:
XID: 181396082
Varnish cache server
[hr]
Well the portfolio url and category urls are working now. Only the menu items for categories still load uncategorized instead of the categories in question. And the individual items are all loading 404s as the category is not added to the slug. The saga continues…


#3

Hey! We’ve been chatting in your ticket :slight_smile:

So the zip was (I think) fixed with PHP 5.4 being activated and more memory thrown at PHP. I also whitelisted backupbuddy folders in Varnish to stop any caching.

The URLs may just need permalinks to be re-saved and cache to be flushed. I made a new CPT on a non-DP site yesterday and had to do that :confused:


#4

Hi. Sorry I got lost here. What is the fix for a Broken CTP URL please?


#5

Resaving the permalinks for the site.