DNS not working on an edited sub-domain


#1

G’day and good morning from Brisbane Australia. I’m a lousy typist (and I’ve pre-prepared some of these lengthier introductory sections to make it a little easier on myself. I do apologise for the time when these ‘canned responses’ have run out.

The last person I Live Chatted with, just the other night my time, seemed either busy or too reluctant to get involved, which kind of disappointed me somewhat.

What seems to be the trouble is this: on my account (petermiddleton.net) I have several sub-domains and on 365thankful.petermiddleton.net, (herein referred to as 365t.etc) in particular I set it up to always redirect to www.365thankful.(etc), as it does by default.

The sub-domain 365t.etc contains a blog of daily photographs of things that I am thankful for. Now, having the www. out front is a little defeatist, it takes away from the impact of the intent of the site. Instead, I wanted the URI to read just 365thankful.petermiddleton.net

Now, I’ve been onto live chat before and the consultant suggested I remove it from Google’s hosting and have it as a fully hosted domain with DreamHost. {the chat session was abruptly ended with the consultant saying allow time to have this propagate through the DNS network. It’s been 36hours now – well sufficient time for it to have propagated and it’s still in a pickle. We here in Australia would use some other profanity and I can teach you that later, if you stick around.}

The trouble with that is that I have NEVER EVEN SET THIS UP, so that can’t be the issue and, as I’ve just said, it’s been about 36hours – well and truly sufficient time for it to have propagated through the DNS network – and it’s still not functioning correctly.

Firefox 4.0.1 running on my Windows XP laptop is telling me that I need to turn off cookies and it still fails when I do this. IE, on said same laptop, says that it can’t find the page and offers to diagnose my connection problem (only there isn’t any)

It’s got me totally stumped (confused). ANY help would be gratefully accepted.


#2

you can place the following into an .htaccess file in your main directory

RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^www.365thankful.petermiddleton.net [NC]
RewriteRule ^(.*)$ http://365thankful.petermiddleton.net/$1 [L,R=301]

#3

Here www.365thankful.petermiddleton.net redirects nicely to 365thankful.petermiddleton.net. Looks ok for me.