DNS forwarding


#1

Heya,

I have a website (www.astruggleforpeace.nl) which I used to host myself on DreamHost, but now someone built a new one and put it on his own hosting, so I tried to setup a custom DNS record (A) to forward the www traffic to his server whilst keeping the webmail on DreamHost. Annoyingly it only seems to work for about 50-70% of computers, others still end up on the old Dreamhost-hosted site.

Anyone have any suggestions on how to fix this? Thank you in advance.


#2

Did you put in both a “blank” A record and an A record for “www”?

Also, when did you do this? It can take up to 72 hours for everything to sync up in the DNS system.

Finally, people who’ve gone to the old system may be experiencing cache problems - either browser ones or DNS caching. Check if this is happening and let us know because there are specific solutions for the individual machines (or routers).

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#3

That’s a really good point that a lot of people seen to forget. I can’t count the number of times “DNS issues” have been “resolved” by clearing caches and rebooting. :wink:

And from the OP description of the situation, I’ll bet there is a least some of that going on.

–rlparker


#4

Obviously I could do this for my own machines, but it doesn’t change the fact that a LARGE number of other machines have the same issue. Machines that aren’t mine, returning visitors.

Also it has been over 5 days now.


#5

Sure! I understand you, and I agree something else might be amiss. I was just commenting in general.

Remember the “bad old days” when AOL used to cache a lot of pages? Other ISPs have also been known to cache DNS, too and Windows caching DNS, and routers…it can be a mess at times.

If you share the url, you could get some other tests from users here, which might help sort out what is happening :wink:

–rlparker


#6

Okay, I see the problem now.

It is that whilst I added the new IP for the new host of the website, annoyingly DreamHost forces the old DNS records to continue existing as well. So the URL resolves 2 IPs to look for the site and it’s prolly a random choice where ppl end up. Is there anyway to remove an A record from the ‘non-editable’ area?


#7

I get redirect when I use that link


BUGabundo :o)
promo here
50$ discount with promo code “BUG50” on ALL plans
Free lifetime Domain with “BUGDOMAIN” promo code


#8

Haha, yea… problem is that there is the ‘uneditable’ DreamHost record, leading to the DH page (which is a redirect javascript, bit ugly. Leading to a Plesk page) and the custom record I added, leading to the proper website.

Which means the url resolves to 2 different IPs, and which you land on seems random. On my comp I always seem to land on the right site, but a lot of other people are not that fortunate. Asking Dreamhost through support already if they’d be so kind as to remove the ‘uneditable’ blank and www A-records. :slight_smile:


#9

according to dnsreport (http://www.dnsreport.com/tools/dnsreport.ch?domain=astruggleforpeace.nl) I can confirm that u have two diferent IPs.
I’ve tried to change the default IP of one of my test domains and also failed.
I guess you need to contact support. Open a ticket and let us know how it goes.


BUGabundo :o)
promo here
50$ discount with promo code “BUG50” on ALL plans
Free lifetime Domain with “BUGDOMAIN” promo code


#10

Maybe you could try “deleting” the DreamHost web hosting for that domain? That should remove the “uneditable” A records for that domain.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#11

Thanks Lensman, heh. If you had said so earlier I wouldn’t have had to bother DreamHost support, but all’s well that ends well in the end.

It was pretty simple yes, I hadn’t realized I can still ‘host’ the domain with DreamHost whilst switching off the webhosting service. Well, I had actually looking for a way to turn off webhosting by clicking the ‘edit’ button. And I didn’t find any way of making it not host at the very least a ‘coming soon’ page. So I assumed there was no way to turn it off without removing the domain from my DreamHost account altogether, basically also removing the email etc. I had TOTALLY missed that there were TWO ‘delete’ buttons per domain in the manage domains screen, the big obvious one, and the one in the webhosting column which I somehow didn’t give any thought to. At any rate, using this button removed webhosting for the domain on DH and as such, got rid of the ‘uneditable’ DNS records that were causing the problem. :slight_smile:

Thanks a lot everyone for your time and advice, I’m glad everybody reaches the correct site now. Otherwise the PR campaign we’ve started would largely be a waste.


#12

Yup, the important thing is that you’re up and running. I was out running errands with my wife all day.

I find the delete button hard to find and somewhat unintuitive as well! I made a similar mistake myself and I think it must have been the amazing rlparker who clued me in to this feature in the panel a couple of months ago!

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options