DNS CNAME record


#1

Hi folks,
I registered my site’s name with DreamHost and am hosting it on mobileme. It was simple enough to create a CNAME record for “www” and pointing it to web.me.com but If I go to any browser and put “mysite.com” on the URL field, it says it can’t find the page. If I put the www before the site name I get there just fine. Is there something else I need to do on the DNS settings page to make it work without having to add the “www” to the url field? Do I need another record?
Any help would be appreciated.


#2

It’s been a while since I set mine up, but I added a CNAME for the “subdomain” of * just like I added the CNAME for the subdomain of “www”

However, when I created my domain hosting here, I set it up as a Redirect so that example.com is a redirect to http://www.example.com

And that’s about all I can remember, but that’s how it currently looks.


#3

I set up a separate CNAME record for * and refreshed dns so I’ll wait a couple hours and see if that made any difference. I do appreciate your help. I’ll update.


#4

I’m thinking it’s the Redirect that finally worked for me, and that’d be an instantaneous fix. How do you currently have example.com set up in the panel? If you go to Manage Domains, it should tell you under the Web Hosting column.


#5

I went under the web hosting column and added a redirect per your instructions. I still get the “page cannot be found” message, but after making the changes, the page did say that the change could take a few hours to work so… I also kept both the CNAME records (*, www) under DNS settings. I’ll wait and see if it works. Will keep the thread updated. Thanks again.[hr]

UPDATE
Scott,

You are the man! It took about half an hour, but it appears that adding a redirect worked. Thanks so much for your help.