Dns acting strangely


#1

I had a domain hosted on a Singapore server but moved it to DH,
changing nameservers on 12 Oct. Users in Sgp were able to get the web
page hosted on DH several hours later, and have no problems with email.

However it is a different story from Australia where I am still
getting the old web page from the Sgp server, and webmail resolves to the
same server as well. (Using several different browsers, after clearing
cache.) Traceroute still ends in Sgp today, not LA.

Is there some explanation for this strange behavior?


#2

have you tried going to manage domains in the panel, clicking the DNS button for the domain in question and the “Refresh” GO button?


#3

Hi LakeRat,

I tried your suggestion a little while ago and got the response:
“We’re sorry, you are only allowed to refresh DNS once per 12 hours!” which
is pretty strange since I have never done this before.

In any case this does not explain why people in one part of the world could see
the right server within hours and I am still getting the old server 11 days later.

Regards.


#4

Did you set all 3 new Dreamhost nameservers (ns1-ns2-ns3)?
What does the domain registar (Which one) say?
What does a whois search give?
Have you tried a forced refresh (ctrl F5)?

I persume the date of 12 October is a mis-date in your original post and ment 12 Sepetember?


#5

Hi,

Thanks for the suggestions, and apologies for the wrong date.
It should have been Sept 12.

a) domain registrar is now DH, transfer confirmed on 17 Sept.
Nameservers were changed at previous registrar before requesting
transfer.

b) whois shows
Domain servers in listed order:
ns1.dreamhost.com
ns2.dreamhost.com
ns3.dreamhost.com

c) neither F5 nor shift+refresh on browser makes any difference.
In any case traceroute is resolving to 203.211.159.18 (Sgp) when
user’s other domains resolve to 66.33.201.2 (DH)

Not sure if I am allowed to post links but site is http://www.mako1.com/
(nothing fancy, we just use the domain for emails).

The DH page has the initials ‘DH’ below the shark while the old server
page does not have those initials.

What I can’t understand is why the Sgp people have been able to get
the DH page as early as 14 Sept (and all emails have been going to
DH server) when I am still getting the old page now.

Regards.


#6

Well does seem strange as you describe it.
I get the DH page at location Thailand.

Have you contacted you old registar?
Maybe you have to flush/delete the nameservers from the old registar, since now all is located at Dreamhost.


#7

“Maybe you have to flush/delete the nameservers from the old registar, since now all is located at Dreamhost.”

As I pointed out earlier, nameservers were changed while domain was still registered at the old registrar, and they
worked fine for Singapore users because they were able to get email as well as the web page hosted at Dreamhost
from 14 Sept.

If I am the only person having this problem I suppose I could live with it but some of their customers are in Australia
and I am not sure if emails are going to the old server.

Regards.


#8

In reality it does, “dns propagation” does not happen all at once. When you make a change in dns different parts of the world will see the change at different times. Now granted ttl or time-to-live will never be 11 days. But to say it doesn’t explain it is incorrect. Because forcing a refresh could very well fix the issue.

There is also another possibility, let’s hope it’s not the case tho. The local machine could be virus or even adware infected. I’ve seen certain types that create certain entries in the dns cache (thereby re-directing you for certain sites) and then prevent the local cache from updating and/or being flushed. The only entry that is in fact looked up is one that didn’t previously exist in the local cache. Generally this method will go undetected on a local machine until a case just such as this were a previously visited site changes IP’s (which in the case of average user doing average surfing is rare.)


#9

@tomt

I am only trying to help and give suggestions. I have been on the internet for 15+ years and with DH almost 7 years.
I have NEVER heard of this problem before in my internet life (well I do not know everything)

I will tell you what I am surprised about:
The new forum. It used to be customers helping customer, because DH hardly ever was here (except ANDREW, sometimes).

Now days after the forum changed (FOR THE BETTER !!!), two DH staff are here and replying to this forum.
LakeRat and others know that.

THANK YOU, DREAMHOST for this extra service.

BUT, DH has not been in this topic/post, guess they also have no idea.

At least your “website/email” is online DH or SGP


#10

Hi LakeRat,

The virus possibility is unlikely as I run an updated Debian Squeeze with no external programs.
However to satisfy ourselves I just ran a Knoppix Live disc, and still get the Singapore server
on browser as well as on traceroute.

The ‘good news’ is that I can now access the web page on DH server - using Anonymouse :frowning:

@ronthai: I am sure that sooner this matter will resolve itself and I’ll post the news. I can hardly
expect DH staff to help on a problem that has little precedence and no one has a clue on what
is going on.

Regards


#11

I can now add the following details:

a) Another party in this area is able to get the DH web page on her machine so
I think the problem may be confined solely to my machine (or more likely the network).

b) Evolution email: sending emails to the domain go to DH server but receiving
emails point to 210.193.7.173 which is a Singapore server.

We have not solved anything so far but have narrowed the problem which is not unhelpful.

Regards


#12

Hi, Andrew (and I) were off for the weekend so I suspect we both missed this till now.

mako1.com resolves to 173.236.186.216 right now (which is a DH VPS server). One of my favorite DNS propagation tools is http://www.whatsmydns.net/#A/mako1.com

A traceroute from the US gives me apache2-ichiban.dnoces.dreamhost.com (173.236.186.216) which is correct based on what I can see on our internal system.

Have you tried flushing your personal DNS cache? http://www.techiecorner.com/35/how-to-flush-dns-cache-in-linux-windows-mac/

or trying to access from a different network yourself? Like from a coffee shop or internet cafe?


#13

Hi Ipstenu-DH,

Thanks for the response. Resolution of mako1.com to 173.236.186.216 is
odd since site is not on a VPS but on a shared server. When I try another
domain on the same user account I get ‘rampart-0.hq.newdream.net (66.33.201.2)’

$ sudo /etc/rc.d/init.d/nscd restart
[sudo] password for tomt:
sudo: /etc/rc.d/init.d/nscd: command not found

/etc/init.d/ does not have a nscd file.

However I will be going to town on Friday and will check the website on another
machine (not being difficult - I live in an isolated area).

Regards


#14

You know that the mako1.com domain is under the other user, right? All the domains under that user are on the 173 box (which is shared, my bad, mis-read it).

Your server looks like it’s 69.163.150.58 for the other domains.


#15

mako1.com as well as spryasia.com are under the same user. I am still getting
the following as last hop for spryasia.com:
23 rampart-0.hq.newdream.net (66.33.201.2) 1125.213 ms * *

On the other hand my own domains resolve to:
26 router-0.hq.newdream.net (66.33.201.1) 939.300 ms 921.913 ms 921.928 ms

I wonder if I should go back to bed and make a new start? :slight_smile:

Regards


#16

http://www.whatsmydns.net/#A/spryasia.com shows the same 173 to me. Every domain on that account is on the 173 server.

Did you flush your DNS cache? Wave a chicken over the computer? (old joke)


#17

I have to confess ignorance on flushing DNS cache - earlier instructions failed
as I pointed out above. I assume all services in init.d dir are restarted when I
rebooted, as I did about 24 hours ago when I ran the Knoppix disc. I will be
happy to try another way of doing this if you provide instructions.

whatsmydns does show 173 for both spryasia.com and mako1.com but
traceroute from here shows something different.

Will pick up chicken on next trip to town.

Regards.


#18

I feel pretty confident saying that your accounts here are fine, and something between you and us is going bibbeldy.

If you’re on Windows, go into DoS shell:

If that doesn’t work… I would change your DNS to use Google’s: https://developers.google.com/speed/public-dns/


#19

I am equally confident this is not a problem at Dreamhost.

If you have read the thread you’ll know that I run Debian Squeeze, not Windows,
and the link provided to flush dns does not work. In any case this is irrelevant since
I am getting the same results on Knoppix Live.

I need to find someone using the same satellite isp and see what they are getting.
Looks like I will have to join another forum to check this out since I do not know
any personally.

Will keep you posted.

Regards.


#20

Blaaah, I did read and my brain fell out. Knoppix would still be going through your DNS, though, right? You should be able to change to Google (or OpenDNS) and circumvent (which I had to do recently when my ISP went and died about it)