DNS - A record, method changed?


#1

Before, I used to just add a subdomain and park it, then add an A record to it and it would work.

But that seems to have changed, and even though I have custom A records on some subdomains, (like site.prodigywow.info is supposed to resolve to 213.113.255.101, but it’s been quite a while and it’s still not doing it (it does, however, resolve to DreamHost…))

I did try removing the subdomain and just adding an A record, but that just gives me bad_httpd_conf.

http://site.prodigywow.info/

How would I go on about adding an A record, then?


#2

if you want to add a subdomain that is hosted by or points to dreamhost then you’d better add a new domain and type the whole url in the domaineditbox.

e.g: site.whatever.com

few minutes later it’s done if dns travels fast


#3

Yes, but I want to add an A record so that it goes to another machine, not DreamHost.


#4

Go to: Manage Doamins
Click “DNS” next to the domain you want to add the A record to.
Type the subdomain name in the name box.
Select A for the record type.
Type the IP ADDRESS of the machine you want the subdomain to point to.
Click add record now.

If the non DH machine is using apache VirtualHosts you will probably get an error message because the server wont be setup to understand this subdomain.

If you have control of the machine add: ServerAlias sub.domain.tld to the VirtualHost and restart apache.


#5

Strangely, this time it worked almost instantly… lol.

Last time I tried doing this without adding a subdomain and parking it, it would simply not resolve AT ALL (even after I have waited several days). (and yes, I did the EXACT same thing…)

Thanks! <3