[django] Http error 404 during running of django-setup.py


#1

i have followed this tutorial, but in step 4 when i execute python django-setup.py from /home/user/domain_folder/ (that contain /public folder) it throws this error:

Looks like your domain is probably [i]mydomain[/i].com ... cool. Testing domain service... Traceback (most recent call last): File "django-setup.py", line 69, in <module> if urllib2.urlopen("http://%s/django-setup-test.txt" % domain).read() != cookie: File "/usr/lib/python2.5/urllib2.py", line 124, in urlopen return _opener.open(url, data) File "/usr/lib/python2.5/urllib2.py", line 387, in open response = meth(req, response) File "/usr/lib/python2.5/urllib2.py", line 498, in http_response 'http', request, response, code, msg, hdrs) File "/usr/lib/python2.5/urllib2.py", line 419, in error result = self._call_chain(*args) File "/usr/lib/python2.5/urllib2.py", line 360, in _call_chain result = func(*args) File "/usr/lib/python2.5/urllib2.py", line 582, in http_error_302 return self.parent.open(new) File "/usr/lib/python2.5/urllib2.py", line 387, in open response = meth(req, response) File "/usr/lib/python2.5/urllib2.py", line 498, in http_response 'http', request, response, code, msg, hdrs) File "/usr/lib/python2.5/urllib2.py", line 425, in error return self._call_chain(*args) File "/usr/lib/python2.5/urllib2.py", line 360, in _call_chain result = func(*args) File "/usr/lib/python2.5/urllib2.py", line 506, in http_error_default raise HTTPError(req.get_full_url(), code, msg, hdrs, fp) urllib2.HTTPError: HTTP Error 404: Not Found

raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)

urllib2.HTTPError: HTTP Error 404: Not Found

I think that 404 refers to http://domain/django-setup-test.txt file (e.g. the first lines of log), but i have created this file before execution of django-setup.py, so i don’t uderstand why this exception.

It could seem that public folder have bad configuration. (if i put index.html in public folder, http://domain/index.html throws 404 http error, quickstart.html doesn’t throw 404 error)

How can i resolve?


#2

What are the permissions on django-setup-test.txt?


#3

I have setted 777 permissions for ‘public/django-setup-test.txt’ file, but the results is the same.


#4

I’m not sure what might be causing that, but that’s definitely the source of your problem. Are you sure you’re looking under the right user?


#5

Resolved. I wasn’t looking under the right user.
Topic can be closed.