Display Long File Names


#1

Hi, is there a way to adjust the display of the file list (on the webpage not ftp software), the directory of the first column is so short that could hardly make any longer name completely shown.

I have no knowledge on web programming, can anyone show me step by step? I’m using fetch on mac. Great Thanks!

Also about the Stats directory, everytime when I tried that site, it pops up a username and password which is not the panel login account, can anyone let me know what it is, where to register?


#2

There’s not much you can do to change the default file list format on a web directory. I think that you’re pretty much limited to changing the icons.

For the stats, did you try what was listed in the Wiki?
http://wiki.dreamhost.com/Accessing_Stats

-Scott


#3

You can change the width of the filename using the command ‘namewidth=??’

You have to place this command in a file called .htaccess (note the dot) and place it in the folder.

You could use a text editor to make a text file called htaccess (no dot) on your PC containing these lines…

Options Indexes MultiViews FollowSymlinks IndexOptions FancyIndexing IconHeight=16 IconWidth=16 NameWidth=60 DescriptionWidth=30 You would then upload using ftp/fetch(?) to your folder containing the filenames. Then use your ftp program to rename htaccess to .htacces (with the dot).

The namewidth of the filenames will now be 60 or whatever you picked.

You can set your username/passwords for site stats from the Control Panel here


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK! :@

Act on my advice at your own risk!


#4

Thank you very much.
Yet I still encouter problem, when I put the file under the folder I want, it simply display:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@darajan2.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Do I have to enable Htaccess/WebDAV feature inside dreamhost panel first? But if I enable that, I seem to not be able to delete that dot file it generates automatically.


#5

Make sure that you create the htaccess file using plain ascii text i.e. Windows notepad, Linux Pico or the Apple equivalent.

You must also ensure that the htaccess file is uploaded in ascii format not binary. You can probably ensure this by uploading the file as htaccess.txt.

Then rename it the file to .htaccess once it is on your DreamHost account.

If you use the Control Panel to create .htaccess then you should use the Control Panel to delete it.

It may be a problem with the ftp program you are using where you would need to rename the file from .htaccess to htaccess.

The result will be this…

It might be an idea to let everyone know what OS and editing/ftp programs you are using as well.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK! :@

Act on my advice at your own risk!


#6

FYI…for the Apple equivalent, there is a FREE gp text editor textwrangler made by the authors of bbedit.

http://www.barebones.com/products/textwrangler/