Disabling Run PHP as CGI option? Expression Engine



I am looking to install the core version just to try it out. I ran the compatibility wizard from EE’s site and the URL rewriting isn’t supported. I checked the wiki and it said that:

“One thing to remember is that in order to use search engine friendly URLs you need to disable the “Run PHP as cgi option””
–> http://wiki.dreamhost.com/ExpressionEngine

Does anyone know if you disable that on Dreamhost’s or EE’s control panel? and if Dreamhost’s - where would I find that?? I’ve looked all around I can’t seem to find it/


You would have to do that from DH’s panel… but it’s not an option anymore. You are basically forced to use PHP as CGI. But then I don’t really understand why that would be required for EE to use URL rewriting … I haven’t used EE for a while, but the wiki article also seems to be out of date.


Promo-Code: [color=#CC0000]SAVEMONEY97[/color] - Save [color=#CC0000]$50[/color] on your first year of hosting.
Get more promo codes here


I actually just went ahead with the install and it seems to work well. Maybe the ‘fast CGI’ option is the replacement for the old option that isn’t there anymore. It’s the only thing I found (while editing the domain) that sounds remotely like it was what I was looking for. That option is auto selected as ‘OFF’ when adding new domains/sub-domains to your hosting.

Thanks for the reply- much appreciated.