Disabling mod_php if all sites are using PHP FastCGI?


#1

The Dreamhost wiki says you can save memory by disabling mod_php if all PHP-driven sites are already using FastCGI:

If all domains are set to use FCGI or CGI for the PHP mode, you may safely deactivate mod_php in the PS configuration to save a good deal of memory. All modern PHP applications will run fine exclusively on fcgi.

Is this true?

In the VPS panel it sales the opposite:

Removes mod_php from the Apache web server. This will save a significant amount of memory if your site serves a lot of static content. PHP-intensive sites may benefit more from setting all domains to use mod_php in Manage Domains and enabling a PHP cache.

I tried disabling mod_php yesterday and my image thumbnail resizer stopped working and gave internal server errors. I’m not exactly sure if this was the reason, or if it was something else going on as we were configuring the server. At the moment, all domains are set to a FastCGI variation of PHP.


#2

It actually says the same thing in a different way.

  1. If you’re using FCGI/CGI for PHP you can disable mod_php and save memory

  2. If you remove mod_php you will save memory on static content, though PHP sites may actually still run better

So it’s the same thing. I noticed you had a lot of WP sites. Are they the ones with the errors and thumbnail issues? What thumbnail resizer are you using?


#3

Thanks for the response. I have 3 small wordpress blogs, but that’s not where the problems are.

Here is the URL to one of my sites where the image resizer is: http://goo.gl/iB0fD . I have a 3rd-party script to dynamically resize images and cache them as well: https://github.com/lencioni/SLIR

Once I disable mod_php, the image resizer fails and gives an internal server error. Here is an example of an URL that fails: http://goo.gl/PA3V99 .

I’ve re-enabled mod_php so they should be working again though.