DH panel completely unstyled, unimaged for last week - cannot use support links


#1

I cannot use panel.dreamhost.com on any browser to reach support.
Windows 7 Pro 64-bit
Chrome, Firefox, Opera - all of them show the panel as unstyled and unimaged.
I can do things like add or remove domains, but I cannot use the contact support functions.

When I click the ‘Contact support’ link, I get a page that asks me to select a category - all unstyled, of course - but when I pick any category and click ‘Next -->’, it comes back to the same page with the categories all unchecked.

It’s been that way for days. Now that I need to contact DH, I cannot.

Is anybody else seeing this?

Is anybody at the helm?
< tink tink >
Hello?


#2

do you have noscript installed? or some other plugin which lets you selectively block scripts? that may be blocked in your browser which would make the panel look strange and not function properly.


#3

[quote=“bobocat, post:2, topic:57778”]
do you have noscript installed? or some other plugin which lets you selectively block scripts? that may be blocked in your browser which would make the panel look strange and not function properly.
[/quote]bobocat, thanks for your reply.

Only on firefox, and Noscript is set to allow DH. In other words, it worked fine last week with my current settings. All of my other browsers are unhampered. I double-checked on everything except safari. Interestingly, within minutes of posting about this, the styles suddenly came back. I cannot help but wonder if this wasn’t a coincidence. Especially since it’s been days.

I’ve been making changes on several accounts using it unstyled and in different browsers because I have different accounts logged in on different browsers. I supposed DH would figure it out sooner or later.

So I’m curious if anyone else noticed this too.

EDIT: Huh - now here’s the weird thing. I’ve got styles in Firefox, but not in any of my other browsers. I have not flushed any caches.

@Andrewf? @RLParker?


#4

Never seen it. Panel’s been working great for me.

Have you tried ctrl-f5?


#5

[quote=“LakeRat, post:4, topic:57778”]

Never seen it. Panel’s been working great for me.

Have you tried ctrl-f5?
[/quote]Thanks for the suggestion LakeRat. It looks like the issue is now completely resolved for all browsers. I have no explanation why this should happen at all. I still haven’t cleared any caches. Meh. If nobody else has noticed it, I’ll just keep an eye open.

Cheers.


#6

The bad content in the cache probably expired.

I can’t remember the last time I actually cleared a browser cache to solve a page loading issue. Ctrl-f5 forces a refresh of the page from the server, I suspect it would have solved your issue right away.


#7

Me neither. Ctrl-f5 is a no-go. This is really frustrating because I can’t use send support an email to tell them about it.

I wonder if they’ve got my charter ip set in a range for search engines or something wonky like that.

None of my browsers will render styles images or javascript for panel.dreamhost.com. I get the favicon, but that’s it. The panel is nigh unusable without javascript.


#8

Try the Firebug add-on for Firefox, or similar plugins for other browsers. Firebug at least has a “Net” panel. It will show the requests being made when the page is being fetched. So you will see if the CSS and image files are being fetched and what the response is.


#9

I have noticed this, but only on Internet Explorer 8 @ work - which when combined, really doesn’t surprise me :slight_smile:


#10

[quote=“Atropos7, post:8, topic:57778”]
Try the Firebug add-on for Firefox, or similar plugins for other browsers. Firebug at least has a “Net” panel. It will show the requests being made when the page is being fetched. So you will see if the CSS and image files are being fetched and what the response is.
[/quote]Atropos7, Thanks for your reply.

Excellent - now we’re getting somewhere. Everything from secure.newdream.net is aborted. It also explains why page renders take forever. Each aborted call lasts for many seconds. Unfortunately, as I said, it happens on all browsers, not just firefox.

I also checked it out on my wife’s computer. Hers has no problem with it.

When I go to secure.newdream.net directly, I get a screen as quoted below.

Of course, once I clicked ‘Continue to Site’ all problems resolved. Nevertheless, dynDNS is suggesting that secure.newdream.net is harboring known spyware. Someone at DH might want to take that up with the folks at dynDNS.com. I’ve disabled the ‘DYN Internet Guide’ in my dynDNS systray app. Now things resolve as expected.

Cheers!

[quote]Internet Guide
by DYN

secure.newdream.net is blocked in your Defense Plan
Content Blocked

This is a known Spyware? website, which is blocked as specified in your Defense Plan?

(A Defense Plan is a tailored configuration which allows you to add content restrictions to your network(s). A single Defense Plan can be used for multiple networks, and you can swap Defense Plans at will to allow or disallow particular types of content.

For more information, please see: http://www.dyndns.com/services/dynguide/readme.html#plan)

Get Me Out of Here
Continue to Site[/quote]


#11

Argh. I think we’ve had a very similar problem with DynDNS in the past. I’ve forwarded this to the appropriate folks internally.


#12

Thanks, andrewf


#13

There used to be a setting where you could speed up the panel by allowing some parts (images, css, and possibly scripts) over plain http rather than https. If you can find that setting and enable it, it may help. I can’t find where to set it anymore though.


#14

[quote=“bobocat, post:13, topic:57778”]
There used to be a setting where you could speed up the panel by allowing some parts (images, css, and possibly scripts) over plain http rather than https. If you can find that setting and enable it, it may help. I can’t find where to set it anymore though.
[/quote]bobocat, thanks for your reply.
It was only slow because secure.newdream.net had been denied by the ‘DYN Internet Guide’ firewall. Once I removed that obstacle, pages are rendered quickly and cleanly.


#15

I removed the “insecure images” option about three months ago. It hasn’t made a significant difference in load speed in a very long time — computers have gotten significantly faster, so SSL isn’t as much of a performance hit as it used to be. More importantly, though, it was insecure, and caused most modern browsers to throw “insecure content” errors, often refusing to load any images or CSS for the panel in the process.

In lieu of flowers, donations can be sent to the OpenSSL project.


#16

I’ve been having this same problem for the last few days. Every once in a while I refresh the page and it starts working.

HttpFox is telling me that it is indeed secure.newdream.net that is being blocked. The worst part is that I can’t use the trouble ticket system. Am I just sol? Is there an alternate URL I can use which isn’t likely to be blacklisted?

Thanks