Detoured in a Drupal Daze


#1

I carefully followed the directions specified in http://wiki.dreamhost.com/Drupal#Drupal_5.0_Update:

-I set up a mysql database exactly as specified in step 1.
-I diligently downloaded and uncompressed the latest version of this software (v. 5.2) from the Drupal website.
-I skipped step 3, exactly as specified in the Drupal 5.0 update
-In accordance with step 4, I FTP’d the contents of the uncompressed directory to my designated location on my website. I also generated an additional directory titled /files/ and right clicked it to modify it to the setting 777.
-Having performed these steps, I then directed my browser to my site location (http://www.yes-virginia.com/Marysfamily), as specified in the Drupal 5.0 update.
-This automatically forwarded the browser to http://www.yes-virginia.com/cgi-system/install.php
-At that page I was greeted with the error message: Not Found The requested URL /cgi-system/install.php was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Most frustratingly, I have retried following all installation instructions three times, even having an assistant monitor my keystrokes to ensure that I am completely following all procedures. However, every time the result is the same.

Oddly, I do notice that there is a file called install.php in the top directory. However, there is no subdirectory named “cgi-system” at all.

I am pretty clueless on how to proceed. I really don’t understand what’s going wrong here. Any advice will be greatly appreciated.

Best,

Mary D.


#2

I think part of the problem here is that you have Drupal running under a directory (/Marysfamily), instead of in the document root. By default, Drupal expect to be running in the document root of a webserver.

I’d drop a line to Drupal tech support and see if they can help.

Good luck!

– Doug

My Website - My Blog


#3

Mary,

This sounds to me as though the “index” file (index.php, or index.html?)in “http://www.yes-virginia.com/Marysfamily” might be using and environment variable to derive the path for install.php, and that the variable being used has a value the programmer was not expecting, due to DreamHost’s use of PHP-CGI.

This is actually a pretty common issue when installing PHP applications. Some commonly used environment variable shoe the path of the cgi-system instead of the path of the script when PHP-CGI is used.

It is usually pretty easy to fix this by simply changing the variable used, or actually “hardcoding” the correct path into the file in place of the programmer’s chosen environment variable.

Can you post the contents of the “http://www.yes-virginia.com/Marysfamily” index.php file here for me to look at? If you do that I might can tell you the “fix” that is needed to complete your install.

–rlparker


#4

Here is how I fixed mine this evening (in addition to several beers) - I found this link to be extremely helpful:

Even though the DH wiki says it is not necessary to change the settings.php file I went ahead and uncommented the $base_url flag and set it to where drupal is installed.

Fingers crossed it seems to now be working.

Hope this helps :slight_smile:


#5

[quote]Here is how I fixed mine this evening (in addition to several beers) - I found this link to be extremely helpful:


That’s sweet! Thanks for passing onthe informatioin! :slight_smile:

–rlparker