Destroyed everything implementing multi-site. Can I restore?

wordpress

#1

Here’s a little more color on what I’ve done to destroy everything…

First, I was attempting to re-configure our site to a multi-site in Wordpress.

So, the two primary files I edited are (not sure if these ring a bell or are unique to WP):
.htaccess
wp-config.php

During installation, an update of Wordpress version was recommended, as was deactivation of all plugins to do so.

Once multisite was established and plugins updated and reactivated, all widgets were reset/eliminated and web copy throughout the site became littered with strange/special characters that would take weeks to restore manually in each post.

I stupidly freaked out and went in to amend the .htaccess and wp-config.php files and restore them to their originals.

Now, all links are broken even though the multisite is now disabled.

I tried to restore everything to the way they were a day ago by using the option in the domain management section of DreamHost, but with no luck. Links still broken.

Trying to identify if there’s a way to go back to the old Wordpress version/settings and restore all of my content using the backup files? I’d love a magic erase button if anyone knows of one!

Thanks so much in advance.


#2

Mistake #1: Either update WordPress, or convert to multisite, but not both at the same time.

This actually sounds like an encoding problem.

[quote]
Trying to identify if there’s a way to go back to the old Wordpress version/settings and restore all of my content using the backup files?[/quote]

If you have your original version of .htaccess and wp-config.php, you should upload those to your root directory and everything should work just fine, as those are the only two files you need to edit to enable multisite.

Have you tried clearing your browser cache and viewing your site again?

Can you provide us a link to the site so we can get a look at the odd characters?


#3

Thanks kjodle

Our site is at castletonpartners.com. However, you won’t be able to access any of the content with the special characters, as the links are all broken.

I’m quite worried that I can’t even access our database to upload the SQL backup file.When I click the phpMyAdmin link in my DreamHost dashboard, I get a “failed to open page message”.

This seems to be a major problem. Has the path to all of our content been moved when the multisite was established? Can I restore those paths?

Thanks again for taking the time to help me out
[hr]
You know what? I think that because I was following a video tutorial at the time that instructed me to create a blogs.dir folder (but those instructions were NOT provided by WP during the network setup), perhaps that’s the mistake that’s moved the content and I can’t find it now that the .htaccess and wp-confi.php files have been restored?

Should I get rid of that directory? Don’t know how to do that safely, unfortunately :frowning:

Still confused why my widgets aren’t displaying even though when I view the page source code in my browser, the content is still in there.


#4

Hi! Sorry I was off in the woods and I’m still backlogged. Lemme grab my Master of Multisite Hat!

Database - You can cheat. go to yourdomain.com/dh_phpmyadmin/mysql.yourdomain.com and you can get in. Sometimes the alias breaks if you move servers. Open up a ticket and tell them that the mysql isn’t redirecting to phpmyadmin :slight_smile: Now that said, be very careful when you import your old DB over. You’re on Multisite. Strange things happen on Multisite. If you don;t want to be on multisite, of course, you should read this: http://wpmututorials.com/how-to/how-to-disable-multisite/

blogs.dir - This is OLD. If you’re on WP 3.5 or later, gleefully ignore that information. You can just delete it. It should be in wp-content, but I don’t see that either so don’t worry about it. If WORDPRESS told you to make it when activating multisite, that’s different. Trust WP over the videos, always.

Weird Characters - This is due to your WP install being so out of date. When you upgraded, the wp-config.php was missing some of the newer calls (like define(‘DB_CHARSET’, ‘’); ). I went ahead and rebuilt your wp-config.php using the wp-config-sample.php file (your old one is now wp-config-old.php), and just pasted in your sql and DB info. Yes, it really is that easy :slight_smile: Characters back to normal! This is a very rare case, but it says you’ve been on WP since the 2.x days, and at that, I commend you! :smiley: (I cannot suggest people ‘fix’ the DBs anymore because it’s insane and complicated, and I’d just rather install a fresh WP install and do an import of the content at this point). There may be a couple outliers of weird content pasted in, but I did a spot check of pages and didn’t see any.

Widgets - I see categories and archives… Is that what was missing?

And a moment of self-pimping, I wrote WordPress Multisite 101: https://store.halfelf.org/ebooks/wordpress-multisite-101/ (it has a sequel but don’t worry about that), and while it’s $7.98, there are discounts on the sidebar. Feel free to grab a copy and read it to get an idea of how and why all the moving parts of Multisite come together.


#5

Thank you so much! What a huge assist from you both, it’s a massive relief!!

I haven’t contributed much to forums over the years, primarily because I’m a total noob and I always wing it. But as someone who benefits often from your expertise, I’m super grateful for these communities and helpful folks!

If anyone else has problems with broken links like I described above, my issue was resolved by going into the dashboard Settings > Permalinks > Save, which refreshed (I think) the paths. (Unless it was Ipstenu-DH resolving it behind the scenes on my behalf, in which case I thank you again).

It seems that all of my previous widget content is now gone. But that’s the least of my worries. I will rebuild them once I can figure out why some of the functionality (e.g. specifying which pages they display on) has vanished.

Or maybe I can upload a backup file to get them back?

Regardless, thank you all again :slight_smile:


#6

The widget info would be saved in your database, in the wp_options table. But check first if they’re in the disabled widget secton at the very bottom.


#7

I never wrote back to thank you again, but I just wanted to say how much I appreciate your help. We’re back up and running :slight_smile:

I also want to purchase your book on Multisite 101, but can’t seem to add it to my cart in the warehouse. Is there another place to buy/download?

Thanks again! :slight_smile:


#8

I just checked and the site and cart are running fine… You’re not using IE 7 are you?

If it’s still failing, use the contact form (https://store.halfelf.org/contact/) and I’ll send you a copy!