Delicious Library


#1

Anyone out there successfully using Delicious Library? I’m finding it works only part of the time.

It seems like the first time or two I try to sync, it works beautifully, but then when I add or delete stuff, and try to re-sync, it times out.

I’m getting a very vague error message:

[QUOTE]We encountered an error when publishing your library to your FTP site at “www.medelle.com”.

The operation couldn’t be completed. Getting a directory listing failed. Your server didn’t respond to us for too long when we tried to contact it, so we gave up.

The file which failed was “/medelle.com”.[/QUOTE]

I know my settings are correct because it worked once, but then subsequent tries it basically times out.

Anyone got any ideas?

EDIT: I also tried flushing my DNS cache but still received the same result.

EDIT 2: It appears that if I completely exit the program, re-open it, and THEN sync, that it works. Workable solution, albeit a bit of a hassle.

I’d still like to know why this is happening though.


#2

COMMENT: if you resolving to the host that won’t help.

COMMENT 2: I’m not sure what program you are using to “sync” but I would look at your local computer to try and resolve the problem, this doesn’t sound like a server issue.


#3

Delicious Library syncs within itself.

i.e. In the preferences you can set up an address using FTP to upload your inventory to be online at a specified address. I can do this only once within the program before I have to exit and restart the program.

The FTP settings are correct as it is working, but it requires a restart of the program everytime. This shouldn’t be the case. I should be able to press “Publish” and have it publish to the site.


#4

Does it have Options in the FTP settings (things like “keepalive” or “passive” or the like) ?


#5

Nope. Nothing like that. Just FTP and FTPS.

In thinking about it some more, I’m thinking it’s got to be some sort of bug on the software side rather than the Dreamhost side. It’s clearly making the connection which is what it’s supposed to do, so that’s not the issue and basically rules out it being a Dreamhost issue.

I think I will submit a bug report to the software company and go from there.

Thanks for the help though. It helped me sort through it mentally. :slight_smile:


#6

The error seems to suggest it thinks part of the path is a file.

Might be the .period in .com messing it up.