Deleting iTunes *.m4a files


#1

I’ve been playing around with the DH backup server and rsync. I worked out a procedure that uses a shell script on a Ubuntu linux machine to use rsync to copy a samba mount of My Documents on my XP machine to my backup server account. Although the backup server has been down at times last month, it works pretty slick for incremental off site backups.

My problem however is that during my trials I created an extra copy of my My Documents on the backup server. I tried to delete the extra copy, and got rid of everything except my iTunes music directory. I’ve tried command line ftp and some ftp clients, but the funny character in the *.m4a file names confuses ftp, so I haven’t been able to use rmdir in command line FTP. FTP says file not found. Command line FTP displays the funny character as ?, while FireFTP displays the funny character as a box with numbers in it. I guess that’s the iTunes copy protection scheme.

The DH backup server doesn’t permit shell access, so I’m limited to commands I can do in FTP or SFTP. Any ideas how can delete my extra copy of them?

Will this funny character problem also prevent me from restoring iTunes files from the DH backup server? If so, I suppose I should exclude them from the rsync backup with another --exclude parameter.

This signature line intentionally blank.


#2

The mdel command accepts wildcards, and I think that by default, it prompts you a Y/N for each file. Use the ‘prompt’ command to toggle this confirmation. Not a guarantee, but that’s what I’d try.

mdel *.mp4
Delete FUNNYNAME.mp4?

-Scott


#3

I’ll try that. I already connected with the ftp -i option to cut down on the prompts when trying to delete directories of files.

It looks like hanjin is giving DH problems again. Connection is sporadic.

I was comparing my local directories to the directories that I can’t erase on the server. It looks like just some file names were changed during a transfer, but not all. So I don’t think these directory and file names with the funny characters aren’t part of iTunes copy protection.

This signature line intentionally blank.


#4

Sounds like the file names you’ve ended up with have Unicode characters in their names that aren’t agreeing with your FTP client. Try rsyncing an empty directory “on top of” the directory you want to delete with the --delete option? That should do the trick. :slight_smile:

If not, write in to support and we can SSH in and get rid of the files for you.


#5

Just like last night, connections to hanjin are currently being refused. I’ll have to wait a little bit to try the either of these methods.

This signature line intentionally blank.