Deleting directories give me an error


#1

After I upload a directory with bullet proof ftp, and then try to delete it, it says:

“550 setup: Directory Not Empty” Grrr, I can’t figure it out.


#2

Maybe there’s a hidden file in it, like a .htaccess file.

– Dan


#3

a lot of FTP programs won’t delete directories when there are files in them. Sometimes you can just find the setting in your program and change it, then it will go though and delete all of the individual files and then the directory.

You could also try going in though a shell, and using the “rm -r” command on the directory. But I wouldn’t reccomend if you arn’t familiar with shell cause you might end up deleting something you didn’t mean to.

-Matttail


#4

No matter what I did I couldn’t get BPFTP to do it. I went in, in explorer, and looked but I couldn’t find anything.


#5

https://panel.dreamhost.com/kbase/index.cgi?area=2932


MacManX.com
I don’t work here. I’m just your typical support forum volunteer.


#6

Tried it, it still wouldn’t show any files. This is annoying :frowning:

Thank you every one who responded and tried to help. I know how it is to be the “help” in support forums.


#7

Try to SSH in and run … rm -rf <folder_name>

UberBargain.com


#8

Bump. I still can’t figure this out. I’m pretty sure there is a hidden .htaccess file, but I just can’t seem to get rid of it.

I can’t see it in windows explorer, or any FTP programs. I’m still completely clueless.


#9

Whats SSH? I don’t want to accidently delete crap, like stated above.


#10

Kbase is awesome

this should help. Be brave, as long as you are careful you’ll do fine.

-Matttail


#11

This is a bit late, but I might as well share what I did. I got WS_FTP, and it allowed me to delete un-empty directories.

I’m to scared to do anything else. “Whoops, I erased my site.” :wink: