Deactivate Mirror


#1

I set up the mirrored domain:
www.innisardenorg.dreamhosters.com which looked great so I ‘flipped the switch’ and updated the DNS records which appeared to work as expected.

However, linking to anything from www.innisarden.org ends up at www.innisardenorg.dreamhosters.com. Do I need to deactivate the mirror?

Thanks!
Carol


#2

There’s a place in the WP settings where you set the URL of your site. You need to change it from dreamhosters to innisarden


#3

I did that but the results aren’t good: www.innisarden.org
I can’t even get into the admin panel. Now what???


#4

Nope, that’s much better. Your links are pointing to the correct URL now except for your image which is still loading from dreamhosters.

Check your error logs to find out why your CSS and JS are failing. The URLs look good, but they aren’t loading. They aren’t loading from dreamhosters either.

Is this the same installation as you have dreamhosters pointing at? Why did you set up a mirror? were you moving from another host? Or did you set up dreamhosters as a development version and now you’re switching to live?


#5

I developed the wordpress site using a domain name about to expire on another host. Once it looked good, I set up an account with Dreamhost and followed the instructions for moving a wordpress site. It was working just fine on innisardenorg.dreamhosters.com so I changed the DNS servers. That appeared to work find (www.innisarden.org) until I realized that if I linked to anything on the site it ended up at innisardenorg.dreamhosters.com . I followed your advice and changed the settings in wordpress. This resulted in a bad format, like it didn’t recognize the theme.

I got into phpmyadmin and modified the database, changing ‘siteurl’ and ‘home’ in the wp_options table. I changed the database name in ‘wp_config’ from 'innisarden_org1" to innisarden_org. Don’t remember what it was before. I imported suffusions options but the results weren’t what I expected.

A lot of the links in posts didn’t work. Magically, a ‘1’ was appended to pictures. So I renamed the JPGs, adding a ‘1’. Slowly I’m putting it back together (labor intensive). I don’t know how it got so screwed up.

I’ve got a blog that I’ve been keeping for 3 years and wanted to move it, but after this experience, I’m quite reluctant.


#6

You may want to look into bash scripting if you want to add a 1 to all of your jpegs. That would take 15 seconds, tops.

Anyway, that’s just a symptom of the problem. You should really find what’s misconfigured. It sounds like you’ve got two databases? Why? It’s not advised to just go in and change things in the DB and config files unless you have a reason. Just randomly changing things is just leading to more issues. I think one of the original issues is it seems you have two databases, perhaps neither of which had all of the correct settings.

I think it would be easiest at this point, if it’s possible, to go back a few steps and get it working on dreamhosters first. Can you repeat the steps where you transferred from another host to DH?


#7

I do have 2 databases: innisarden_org_1 and innisarden_org. I can get to innisarden_org with http://mysql.innisarden.org which is the one I modified. Not sure how to get access to innisarden_org_1.

I set this up in early December and didn’t get a chance to work on it again until this week. My memory isn’t so good… :frowning:


#8

Both of your databases should be accessible from the same URL, but with a different username (and password). Check the MySQL section of your panel for the appropriate information.