DB is too large to upload


#1

I’m trying to upload a mysql database to my VPS server via PHPMyAdmin and it says that it’s too big. I went to the MySQL help area and it said:

The first things to check (or ask your host provider to check) are the values of upload_max_filesize, memory_limit and post_max_size in the php.ini configuration file. All of these three settings limit the maximum size of data that can be submitted and handled by PHP. One user also said that post_max_size and memory_limit need to be larger than upload_max_filesize.

So how do I get this upped or is there another way to get the database imported? I bought the VPS so I would have less limits and now this happens. Not a happy camper. Any help you can provide would be really helpful. Thanks


#2

Before you get your knickers in a twist, do your homework and take a look at this:

Every single issue you have mentioned has been answered in the wiki. For those that aren’t, there’s always the University of Google:

https://www.google.com/search?num=50&newwindow=1&site=&source=hp&q=increase+upload+max+filesize&oq=increase+upload+max+filesize&gs_l=hp.3..0l10.1360.14837.0.15095.30.21.1.0.0.1.1207.6997.1j0j3j0j1j5j1j2.13.0.chm_loc%2Chmss2%3Dfalse%2Chms2min%3D10%2Chms2max%3D10%2Chmtb%3D120%2Chmta%3D1440%2Chmrde%3D0-0%2Chmde%3D0-9...0...1.1.45.hp..24.6.1527.-YopTyVHBNs

It can be really useful in these cases if you mention the size of the file in question. That’s not necessary for now, but if you try the solutions mentioned in the wiki and have difficulties, please let us know what you tried, how you tried it, and what the results were, including error messages.

You’ve leveled up, so now there’s an entirely new skillset to acquire. Fewer limits does not necessarily mean fewer problems, just different problems. If anything, I have found that being on a VPS means you have to be even more knowledgeable about how a web server works, but the benefit is that you can do things that shared hosting would never allow you to do. There are always tradeoffs.


#3

You said it better than I did in the reply that I aborted before hitting post.

@phillycodehound
As far as the issues, so you need to set some values to fine tune your VPS… the point is those are not limits, they are settings that are configurable by you.

I’m also not positive where specifically you are encountering error, my guess is your are trying to upload directly into phpmyadmin, if thats the case you might try SFTPing the file to a directory on your VPS and importing from there, that will eliminate the php limitations that I think you’re running into.


#4

How big is this file anyway? If it’s 10 or 20 megs and hits the limit, that;s one thing. If it’s 500megs to a gig, that’s a WHOLE nother ball game :confused: (files that big like to eat tmp space for lunch, I had a problem with a 2G DB I had to move and managed to crash the server, twice, before someone took pity on me)