Datebocks not working on dreamhost (Rails app)

software development


Anybody using datebocks sucessfully on dreamhost?

I have it installed and working great on my local machine, but
on dreamhost I get this “undefined datebocks_field error”.

I’ve killed and started new fcgi processes several times, and triple checked that I have both engines and the datebocks engine installed correctly. My environment config has Engines.start :datebocks, and both ApplicationController and ApplicationHelper include datebocks.

on my local machine I’m using Locomotive 2 (mongrel), and on
production I have the standard apache/lighttpd/fcgi setup, with Rails

one thing I noticed on development was that sometimes I would get this
same error when loading a view using datebocks for the first time
after starting the server, but from the first refresh on it would work
fine. perhaps this is related?

any help would be greatly appreciated, been stuck on this for a LONG time and been having to use rails default, and buggy, date_select

  • Oliver


They just recently upgraded Ruby - was this working before or are you trying to get it working for the first time?



I tried a while back, and it didn’t work… perhaps with the new version of Ruby it’s worth a new try, let’s see


nope, still not working with the new version of ruby…