Database Path

apps

#1

The documentation for moveable type says I need the path to mysql. Is this available at Dreamhost - not the domain for it - but the actual path.


#2

It wasn’t necessary when I installed MT 2.5 or when I upgraded to 2.6 and then 2.6.2. I don’t know about a new 2.6.2 install, though.

In case you didn’t see this link in other threads, my install notes are at http://www.wombatnation.com/misc/installMTDreamHost.html. The database config info that I needed for the actual install is in the section titled “Edit Main Config and Password File”.


#3

Me again…

I don’t get it. I unzipped everything and edited the files as the installation instructions detail. But I am getting 500 errors when I run mt-check.cgi. I looked at the troubleshooting guide and I verified that all cgi files have the right permissions. I have no idea what’s up.


#4

That’s odd. I just tested FTPing mt-check.cgi up to my server in binary mode instead of ASCII, and even that worked fine. Well, I first forgot to chmod it, and that gave me an Internal Server 500 error. After I set the permissions with chmod 755, I was able to review the output from the cgi file without a problem.

Random debugging ideas:

  1. Open the file on the server in a text editor like emacs, vim, or nano to make sure it looks like normal perl code
  2. If you’re not sure what to look for with suggestion 1) above, type “head mt-check.cgi” (without the quotes) at a shell prompt in your mt directory and verify that the first couple lines are:

[code]#!/usr/bin/perl -w

Copyright 2001-2003 Six Apart. This code cannot be redistributed without

permission from www.movabletype.org.[/code]3) At a shell prompt, type “file mt-check.cgi” and verify that you get back

mt-check.cgi: perl script text executable4) At a shell prompt, type “ls -l mt-check.cgi” and verify that you get back

-rwxr-xr-xat the beginning of the listing.

Also, do any other cgi scripts work for you?