Database issue? HELP


I have uploaded the website to my dreamhost server to the voiceamerica folder that was created after the cpanel export. I need to know how do i get my wordpress site to work on this host.


Digging through your site shows a slightly non-standard directory name. It thinks it’s in /home/USER/voiceamerica/, rather than /home/USER/

Edit your wp-config.php file and update the settings. The appropriate settings can be found through the panel here if you click Edit for your domain in Manage Domains (shows you the home directory), and Manage MySQL for database user, password, and hostname. You might even need the DB info to use phpMyAdmin to log into your database to double-check the table prefix.


Okay, I was able to get the website to work accept for the home page? I can view the backend and any other page just fine just not the homepage; it comes up blank.


Go through the Admin’s general settings and make sure the URL for the site is correct. Also, sometimes .htaccess needs to be refreshed, so I go into Settings for Permalinks and re-save my desired Permalink setting and click Save.


I am totally confused right now! I imported my cpanel from a previous host and it created soooo many folders that I am clueless as to which one is the root folder and now on another site only the backend of wordpress works while pages are 404 errors?


If you go into the panel here and click Manage Domains, you can click on Edit for each domain you host to see which home directory it’s using for your website. With that information, you can FTP in and inspect your files.


How do I complete reset my account. I need to start from scratch because the whole cpanel importer function messed me up bad!


Go through Manage Email, SQL, Users, and Domains, and delete each entry.


WIll that delete the stored files as well ?

Thanks for all the help!


It might not delete files, and I don’t think it does, but a simple FTP into your home directory will let you delete anything that’s deletable. If it doesn’t let you delete something, it’s either because you’re not supposed to, or there’s a hidden write-protected file inside that folder.


I was finally able to get it to work…the problem was either the folder i had on root folder OR the default.html OR i just needed to update plug-ins…I did all three at the same time so its hard to tell which one did the trick. THanks for the help.