Database error


#1

Hi, I’ve browsed the other threads on this topic but have not found a solution to my problem.

I migrated wildozark.com to my vps. The database imported correctly, I think. I’ve changed the settings in my wp-config.php file and it still gives me an error when I try to see the website.

Here are the things I think could be the problem…

My DNS are already pointing to Dreamhost, but it still says pending when I check at my old host. Could that cause the problem?

Here is what I’ve entered for the database in the wp-config file:

/** MySQL hostname */
define(‘DB_HOST’, ‘mysql.wildozark.com’);

Should there be something else besides this?

The database name is “wildozark”.

The table prefix is the same in the database and the wp-config file, simply “wordpress_”.

What else could be causing the error? I’ve read the codex article on editing the wp-config file and the only other thing I can see might be that I need a port number or something else added to the database or host names.

My site is completely unavailable now and I’d appreciate any help.

Thanks,
Madison


#2

Did you wait 4-8 hours for DNS propagation after you migrated to VPS?

I’m getting a site at wildozark.com


#3

Yes, it had been more than 24 hours, but that wasn’t the problem. I haven’t had a chance to come back here to update, but there were a few issues. One is that I had a 1-click Wordpress installation already running using the same domain, but I’d forgotten I’d done that. Fixed that by using the Manage Applications options, but when I did so, I accidentally erased all of the files I’d transferred over. So I had to start all over again with the transfer. After that, the problem was that on my old host the wordpress installation was in a subfolder and I didn’t change the url in the dashboard before I moved the files to the vps. Afterwards, I updated everything in the wp-config file and reloaded that file via sftp, but couldn’t remember where to go to make the changes that would allow me into the dashboard. Eventually I found out that I could make that change in myPHP. And now it’s all back in working order, after much gnashing of teeth and banging of head and searching for clues among this forum and Wordpress forums, lol.

~ Madison