DAMN RMagick!

apps

#1

I’ve compiled and installed ImageMagick.

I’ve installed gems locally, updated rails & dipendences and successfully installed RMagick 1.14.1…

in my app/controller/application.rb I have

require 'rubygems’
require_gem ‘rmagick’, ‘>= 1.14’

it seems to work but I can’t use RMagick or I get error:

uninitialized constant Image

if I try to change the rubygem include to require_gem ‘rmagick’, ‘>= 1.14.2’

then I get a message like

RubyGem version error: rmagick(1.10.1 not >= 1.14.2)

so I SUPPOSE the system is loading the correct library…

my ENV:
[whopper]$ env
GEM_HOME=/home/etozzato/.gems
PATH=/home/etozzato/local/bin:/home/etozzato/.gems/bin:/home/etozzato/local/bin:/home/etozzato/bin:/home/etozzato/.gems/bin:/home/etozzato/bin:/home/etozzato/.gems/bin:/home/etozzato/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games
GEM_PATH=/usr/lib/ruby/gems/1.8:/home/etozzato/.gems
SSH_CONNECTION=87.4.25.111 49603 208.113.136.16 22
RUBYLIB=/home/etozzato/local/lib/site_ruby/1.8
_=/usr/bin/env

MAYBE NOT RAILS

help.