Customised PHP and Zend Optimizer

software development

#1

Hi fellow DreamHosters,

I originally bought SmartPPC a few years ago and have never really launched it but worked fine on balrog. To get it to work I needed to change some of the PHP.ini settings such as magic quotes etc and had to compile a local copy of PHP 4.4.2 but all was well. When DH moved my account to axl it stopped working with a source guardian error. The developer said it was I had a different IP address now and they had to change the script however they now use Zend Optimizer instead. The problem I have now is that I have installed a new version of PHP5.0 which works fine however it does not include Zend Optimizer and I am getting that error at the index page. DH have said I can install a local copy in my home directory and have given me the link to ZO. I have downloaded the software and I have untared the file however it says I need to run it as root. DH don’t support the installation of this however the bottom line is I need my server to support the following (somehow, although I think the ZO installation is the only stumbling block now):-

PHP 4.3.9 or later - OK
Server API must be Apache - Running as CGI but OK
Safe Mode must be Off (at least Local Value but better if both Local and Global values will be Off) NOT sure about this bit
Register Globals must be On (at least Local Value but better if both Local and Global values will be On) OK
Allow Url Fopen must be On (at least Local Value but better if both Local and Global values will be On) OK
Disable Functions must be No value (at least Local Value but better if both Local and Global values will be No value) OK
Magic Quotes Gpc must be Off (at least Local Value but better if both Local and Global values will be Off) OK
PHP must be supported GD, Freetype, GIF, JPG, PNG, ICONV, Mysql libraries OK
Zend Optimizer 2.5.10 or later Arghhhh!

Any help or suggestion how can either change the default PHP stuff (which I assume you can’t) or how to locally install ZO would be greatly appreciated. I’ve been with DH for nearly 10 years and I don’t really want to have to change ISP’s just because I can’t get this to work.

Cheers

Andy


#2

Aha! I got it working.


#3

how?

Ahhh… I figured it out. Well, might not be the best solution but it works.

Add this to the end of your php.ini

zend_extension="/usr/local/dh/apache/template/phpext/ZendExtensionManager.so"
zend_extension="/usr/local/dh/apache/template/phpext/zend_optimizer5/ZendOptimizer.so"