Custom PHP install

I was following the instructions for a custom php5 install from the DH wiki, and had this error:

gcc: Internal error: Killed (program collect2)
Please submit a full bug report.
See URL: for instructions.
For Debian GNU/Linux specific bug reporting instructions,
see URL:file:///usr/share/doc/gcc-3.3/README.Bugs.

make: *** [sapi/cli/php] Error 1[/quote]

What can I do to finish compiling? Do I have to restart the whole process and how do I avoid the same error?

make “nice”?

I get this, “make: *** No rule to make target `nice’. Stop.”

What did you type to get that? I’m sorry for not being more clear. What I should have said was, "Did you try running make in “nice” mode?

man nice - if you are not familiar with it.


Here’s the script I’m using:


Abort on any errors

set -e

The domain in which to install the PHP CGI script.


Where do you want all this stuff built? I’d recommend picking a local


Don’t pick a directory that already exists! We clean up after

ourselves at the end!


And where should it be installed?


Set DISTDIR to somewhere persistent, if you plan to muck around with this

script and run it several times!


Update version information here.

CCLIENT_DIR=“imap-2004g” # Another pest!

What PHP features do you want enabled?


---- end of user-editable bits. Hopefully! ----

Push the install dir’s bin directory into the path


#setup directories
mkdir -p ${SRCDIR}
mkdir -p ${INSTALLDIR}
mkdir -p ${DISTDIR}

Get all the required packages

wget -c${PHP5}.tar.gz
wget -c${LIBICONV}.tar.gz
wget -c
wget -c${LIBXML2}.tar.gz
wget -c${LIBXSLT}.tar.gz
wget -c${MHASH}.tar.gz
wget -c${ZLIB}.tar.gz
wget -c${CURL}.tar.gz
wget -c${LIBIDN}.tar.gz
wget -c${CCLIENT}.tar.Z

echo ---------- Unpacking downloaded archives. This process may take several minutes! ----------

cd ${SRCDIR}

Unpack them all

tar xzf ${DISTDIR}/${PHP5}.tar.gz
tar xzf ${DISTDIR}/${LIBICONV}.tar.gz
tar xzf ${DISTDIR}/${LIBMCRYPT}.tar.gz
tar xzf ${DISTDIR}/${LIBXML2}.tar.gz
tar xzf ${DISTDIR}/${LIBXSLT}.tar.gz
tar xzf ${DISTDIR}/${MHASH}.tar.gz
tar xzf ${DISTDIR}/${ZLIB}.tar.gz
tar xzf ${DISTDIR}/${CURL}.tar.gz
tar xzf ${DISTDIR}/${LIBIDN}.tar.gz
uncompress -cd ${DISTDIR}/${CCLIENT}.tar.Z |tar x

Build them in the required order to satisfy dependencies.

./configure --enable-extra-encodings --prefix=${INSTALLDIR}

make clean

make install

./configure --with-iconv=${INSTALLDIR} --prefix=${INSTALLDIR}

make clean

make install

./configure --prefix=${INSTALLDIR}

make clean

make install

cd ${SRCDIR}/${ZLIB}
./configure --shared --prefix=${INSTALLDIR}

make clean

make install

./configure --disable-posix-threads --prefix=${INSTALLDIR}

make clean

make install

#libmcrypt lltdl issue!!
cd ${SRCDIR}/${LIBMCRYPT}/libltdl
./configure --prefix=${INSTALLDIR} --enable-ltdl-install
make install

./configure --prefix=${INSTALLDIR}

make clean

make install

./configure --with-iconv-prefix=${INSTALLDIR} --prefix=${INSTALLDIR}

make clean

make install

cd ${SRCDIR}/${CURL}
./configure --with-ssl=${INSTALLDIR} --with-zlib=${INSTALLDIR}
–with-libidn=${INSTALLDIR} --enable-ipv6 --enable-cookies
–enable-crypto-auth --prefix=${INSTALLDIR}

make clean

make install


make ldb

Install targets are for wusses!

cp c-client/c-client.a ${INSTALLDIR}/lib/libc-client.a
cp c-client/*.h ${INSTALLDIR}/include

#PHP 5
cd ${SRCDIR}/${PHP5}
./configure ${PHPFEATURES}

make clean

make install

#copy config file
mkdir -p ${INSTALLDIR}/etc/php5/${DOMAIN};
cp ${SRCDIR}/${PHP5}/php.ini-dist ${INSTALLDIR}/etc/php5/${DOMAIN}/php.ini

#copy PHP CGI
mkdir -p ${HOME}/${DOMAIN}/cgi-bin
chmod 0755 ${HOME}/${DOMAIN}/cgi-bin
cp ${INSTALLDIR}/bin/php ${HOME}/${DOMAIN}/cgi-bin/php.cgi
echo ---------- INSTALL COMPLETE! ----------

Ok. I’m sorry, but I dont understand. What is your question? I thought that your problem was that your “make” processes were being killed before execution was completed. My suggestion was that you run your “makes” using “nice” mode, and I pointed you to the man page for using nice.

Did you research the use of nice? :wink: You probably need to study-up a bit on the process of compiling programs within the shell (there are lots of web resources available for that).

While I did not carefully study your script, I do not see anywhere you used nice in the makes.

I’m also curious as to why you need to compile your own PHP5, as Dreamhost now makes PHP5 available from the panel? If all you need are a few settings changes, it is much easier to just use your own copy of PHP and a customized php.ini (which is described well on the wiki).


No, I didn’t add nice to the script. I was just showing how I came up with my errors. My goal is to install php so that I can have imap support, and I found this script on the DH wiki here: to do the install. I’m going to add the -k modifier to the makes to see if that helps. I don’t quite understand how nice will help with the install.

I understand. Nice might not help, but it is designed to make the compile use less resources, and submit to other processes, in order to allow the complile to “play nice” :wink: . My thought was that it might help prevent your process(es) from getting killed during a make.

The -k might also help. Good Luck with it!


I hit more erros. This time it is:

make: *** [sapi/cli/php] Killed
make: *** Deleting file sapi/cli/php' Killed make: Targetall’ not remade because of errors.
[lira]$ /home/flccorg/php5/lib/libc-client.a(osdep.o)(.text+0x9180): In function ssl_onceonlyinit': /home/flccorg/source/imap-2004g/c-client/osdep.c:300: warning: the use oftmpnam’ is dangerous, better use `mkstemp’

it looks as though PHP was installed (at least all the modules were, but I don’t know how to finish the install).

Wow, you’re having a terrible time getting that install to run without getting killed, and I don’t know what else to suggest other than breaking your script up into pieces and trying to run them one after the other (and I’m not even sure that will help, cause I’m not sure what DH is using to determine when to kill your process) :frowning:

After trying breaking up the script, if I still couldn’t get a clean run, I think I’d contact support, pointing them to this thread so they can see what you have gone through. Maybe they can either relax your process control limitations long enough for you to get a clean run of your script, or maybe even run it for you.


I appreciate all the help. At this point I’ll try adding nice. I’ve reduced the script down some, but I’m having trouble figuring out where it crashed. If I could get that I might be able to resume from that point.

I was trying to get AWStats configured properly, and was running it with the first line. It would typically take about 10-15 seconds, can’t remember the exact time, but would get killed during processing about half the time.

I started using the second line and while it now took 20-30 seconds, it never once got killed. You’ve probably got all this figured out by now, but I just wanted to comment that it wasn’t terribly frustrating in my experience.

“/usr/local/bin/perl /home/username/awstats/tools/ -update -awstatsprog=/home/username/awstats/cgi-bin/ -dir=/home/username/”

“nice -20 /usr/local/bin/perl /home/username/awstats/tools/ -update -awstatsprog=/home/username/awstats/cgi-bin/ -dir=/home/username/”

How long does this make process you’re running typically take? There’s a LOT going on it looks like.

The make process takes a long time. I’m not sure about the particular package you’re installing, but it’ll take at least 30 minutes I’m guessing.

I believe your solution is to replace the “DOMAIN” in the line


to use your domain name as it is at DH…

export DOMAIN=“

That’s in the instructions on the page with the scripts.