Custom php.ini


#1

I’ve followed all the instructions at http://wiki.dreamhost.com/Custom_PHP.ini and my phpinfo() (at http://pubpara.bandstand.org.uk/phpinfo.php) is now showing as reading my custom php.ini file. But no changes I make in the php.ini file seem to make the slightest bit of difference, even if I fill it up with rubbish — no errors or anything. I’m trying to load the ioncube module. Anyone have any suggestions? Thanks!


#2

Your phpinfo.php file isn’t showing up for me. I’m getting an error, so maybe it’s finally working, but your rubbish .ini file finally kicked in.

-Scott


#3

Hi Scott, thanks for pointing that out. That was cause of an htaccess typo which I have now corrected. Same issue as before though :frowning:


#4

Seeing how there are no parameter differences, I’d guess that your php.ini file is corrupted, either due to syntax errors or it has hidden characters inserted by a text editor. How did you edit the file?

-Scott


#5

Scott, thanks for your reply, at the moment I am using an exact copy of /etc/php5/cgi/php.ini which I have edited in the shell using vim. I have tried doing things some simple things like setting some variables which are unset by default, such as user_dir, but none of my changes show up in phpinfo(). I have also tried setting single parameters in an otherwise blank php.ini file.
The IonCube loader helper (at http://pubpara.bandstand.org.uk/ioncube-loader-helper.php?page=install-assistant) tells me that I should still be editing /etc/php5/cgi/php.ini, which it extracts from phpinfo()'s “Configuration File (php.ini) Path” variable. So should this value be different for my changes to work?


#6

Try sXi’s approach:
http://sxi.sabrextreme.com/dh-phpini

And if you’re experimenting with ionCube, sXi’s page also has helpful info on that.

-Scott