Custom php.ini seems impossible

apps

#1

i followed the directions (or at least a modified version that actually half works), and things are just screwy.

first, the directions:

ok, now $HOME apparently doesn’t work, so i had to change it to /home/myusername. (and yeah i changed domain.com) the stuff below the cp lines doesn’t apply to me but i tried this with and without them. i run the php_update from the shell and i get:
command not found2
command not found5
(and when the php.ini file isn’t already there in cgi-bin, a no such file or dir)

ok, so that copies the cgi and ini file to my /cgi-bin. but crazy thing: cuteftp (and webftp) shows a php.ini that’s 22.53 KB, which i cannot edit or view, plus when i upload my php.ini it doesn’t overwrite the other, and even disconnecting from the ftp and reconnecting back it shows BOTH files. at that point trying to view either views my custom one, and trying to delete both only deletes my custom one. i’m unable to delete my cgi-bin folder and start over because it can’t delete that weird file.

ok, now third, i upload my .htaccess:
Options ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi

to my domainname.com folder, and when i run my php script now i get an error 400.

the whole problem i’m having is the script was giving an error, the script author told me to add to the .htaccess:
PHP_FLAG output_buffering on
but that’s not doing anything so he said to do php.ini.
i can’t figure out why this thing is acting so crazy and i’m getting really aggrevated.

-edit-
oh, my custom php.ini:

output_buffering = On
zend_extension = …/ioncube/ioncube_loader_lin_4.4.so
memory_limit = 100M
include_path=.:/usr/local/lib/php:/usr/bin/pear


#2

You’ll have better luck if you stick to the instructions that are posted in the DH wiki. That procedure works.

Why in the world do you need a 100MB memory limit? That is not a very nice thing to pull on a shared server. :frowning:

–rlparker


#3

well, no those on the wiki don’t work. i hafta change $HOME for it to do anything. other than that tho i followed the directions, except some steps for setting up a cron file which i’m not worried about.

as for the MB limit i have no clue what that even does or anything. i’m sure it’s not actually using 110 MB of memory tho…


#4

And you’re using a custom php.ini file?

“The instructions provided in this article or section are considered advanced.”

That means don’t mess with it if you don’t know what you are doing.


Simon’s website
Save $100 on 1-year plans with promo code [color=#CC0000]SCJESSEY100[/color] (details)


#5

Yes, they do, and there are many DH users who have followed those instructions with success.

No, you don’t, if you are following the instructions correctly and understand what you are doing in the shell.

Then you have no business modifying the php.ini Dreamhost has installed for use on your shared server.

–rlparker


#6

ok, i’m sorry but you all are just retarded. do i know what exactly that line does? no. but the dude who wrote the commercial script obviously does. the script is not resource intensive, it ain’t gonna use no 100 megs of ram or anything, i’d say he just stuck a high figure on there because the actual amount doesn’t matter, so long as the setting is changed from off to on.
i know what i’m doing, with the shell and changing the ini and all, and the code on the wiki DOES NOT work. it aint very freakin hard to type some text into a console window. changing the $HOME variable does the job and should make no different. it’s just hard-coding the path instead of using a variable. so for all intents and purposes i follwed the directions.


#7

I’m sorry but, who’s the retarded one who can’t get it to work?
Good luck finding someone who will help you here (for free), with that kind of attitude.


#8

well the “help” i got ths far was just some jackass telling me i don’t know what i’m doing. he’s the one with the bad attitude. i know what i’m doing, i know how to freakin type some text into a shell and upload a file, and whatever else i have to do, but something just ain’t right. coming on here and telling me i have no business changing things ain’t gonna get a friendly response from me. i’m funny like that…


#9

Nice! Okay, you have made your point, and your opinion has been noted. :wink:

The “dude” that wrote the program may very well know what he is doing; that does not mean that you know what you are doing.

Your posts have already made it quite clearly evident that you have no idea whether the script is “resource intensive” or not and that you have no idea how much ram the script is likely to use.

And now you have proven that you are completely clueless about what is involved with these PHP settings, which is exactly why you shouldn’t be messing with them.

No, you don’t know what you are doing, and your statements in these posts make that crystal clear. There is nothing wrong with not knowing something; it’s just lame to act like you do when you don’t. You can say those scripts don’t work as many times as you like, and it does not change the fact that your inability to understand what those shell and perl scripts are doing does not mean they don’t “work”. They do “work”, if you know how to use them. Of course, you never bothered to indicate what instructions you were following, and there is more than one section in the wiki that deals with such stuff - I believe from your code snippets that you were referring to the Wiki article on PHP.ini; those instruction work properly for what they were intended to do, which was to change to max upload filesize. Modifying that to make other php.ini changes is not covered in that article.

That is the easy part - knowing what to type, and why, and how to accomplish your goal, is another thing all together, as you have just proven. Since you “know what you are doing”, you shouldn’t even need the wiki article to solve your problem.

All that said, you could have taken another approach. You might have explained what you were trying to install, and what changes you felt needed to be made, and why. You might have even asked how to set up a php.ini to facilitate your application, but instead you decided that “the wiki article doesn’t work”, took it upon yourself to follow the directions “for all intents and purposes” and then come on here and complain that it didn’t work as expected. You might want to take the time to review How To Ask Questions The Smart Way…and maybe you will learn something. Or not.

The “bottom line” is pretty clear here: since we are retarded and you know what you are doing, you obviously don’t need any help - so knock yourself out! Good Luck with that.

–rlparker


#10

Right! Did it ever dawn on you that you need to know something more than you do?

You may think that you are “funny like that”, but to others it just makes you look the fool. You do not have any business changing security and performance related options installed by your hosting provider, on a shared server, if you do not understand the things you are changing.

If you can’t understand that, then you are too ignorant or stupid to be allowed to change anything on a server where your actions can result in the degradation of performance for others.

–rlparker


#11

well just so ya know i got it all working, figured it out myself. wanna know the problem? the php.ini line that references the ioncube loader. it’s not needed as ioncube can be loaded without it, so i tried removing it and all is fine now.
i’m sure you woulnd’t have figured that one…


#12

Good Deal! And hopefully that 100MB memory limit won’t get regularly used by your script, and all will be well for your neighbors on your server.

I’m glad you got it “sorted” :wink:

–rlparker (aka “jackass”)


#13

i can remove that line if it makes you feel better. i seriously don’t think it’s a problem as it usually isn’t even needed. usually php.ini doesn’t have to be changed, but since i couldn’t turn on that buffering setting through htaccess i had to edit php.ini. so it’s not a needed line so i can remove it. i can ask what the purpose of it is, but trust me, if my site starts hogging memory like crazy DH will let me know…


#14

You can bank on that. :slight_smile:

Remember, there is a limit imposed by DreamHost on the amount of memory a single user can consume, regardless of any limit you set for PHP. Running into this latter limit can result in your site throwing errors when under heavy use.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#15

In a perfect world, it should not make any difference; a properly written script should manage it’s own memory and fail gracefully upon unexpected error rather than “running away”. There is a good chance that, Dreamhost running PHP as CGI under SuEXEC will result in their prockiller just aborting it if it gets out of hand.

The reason I was concerned is that just because a script is “commercial” does not necessarily mean it is well coded, and some such poorly coded applications will take, and use, all the RAM you give them. This is one of the reasons that memory limits on shared servers, where folks are allowed to run their own and 3rd party scripts, are usually set with a much lower memory limit - usually in the neighborhood of 12-16 MB.

That is true enough also. You certainly do not need to remove the line for my sake (you are not on the same server as me, so I’m only “generally” interested :wink: ). The lower limit is only there as a safety mechanism - since DH lets you change it, the responsibility that goes with a higher setting lies with you. I just wanted you to know what was involved. Actually, if you review the thread, I was just curious to know why your application thought it needed that much RAM.

It could be that it doesn’t, but that the developer figured “I’ll take all I can so it will run faster” - which is great if you are on a dedicated server and have lots of RAM but “not so great” if a lot of other users are sharing the RAM in a box. :wink:

–rlparker


#16

It looks like you might be losing track of your various personnae, Bob. This is really much more of an “Anonymous2” type post than an “Ardco” post. Are you having some difficulty keeping the various personalities/puppets sorted? :wink:

–rlparker


#17

The only troll I see in this thread is you.
Take it to PM if you’re going to be an idiot, your pointless bickering has nothing to do with the OP’s topic nor is it helping him with this issue.


#18

Considering the number of times rlparker and myself seem to post simultaneously to a thread, I think the likelihood of us being the one person is remote, but I am flattered you would think that. :wink:

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#19

If you could actually explain what trouble your having in understanding the wiki’s instructions, which to me is what it appears to be, I think most of us would be happy to help you.
It just seems you’re more interested in blaming someone/something (the wiki) for your own inability or lack of experience.
I personally don’t mind helping you, if you can get around that, and preferably explain in detail which portion of the wiki you had problems with. Your original post, as it currently stands, doesn’t honestly help me figure out where you went wrong in the wiki.


#20

Actually, I’m also flattered that you think Mark and I might be a single person…he often gives better answers than I do, and I’d love to take credit for them.

Plus that would mean that “rlparker/raz2133” would have (now) 4,029 posts on this forum…and that would be a lot more impressive that “98 posts to go to DreamMaster!” :wink:

–rlparker