Custom DNS or Sub-Domain?


#1

Hi!

I’ve been reading the Wiki for Custom DNS records.

I am going to be running (at home) a SIP/VoIP server and want to use voip.mydomainname.com

Now, I think what the Wiki is telling me is to not add voip.mydomainname.com as a sub-domain with hosting (round robin or something?) but instead, when I go to add a custom A record for the domain, to specify voip in the ‘Name’ area of “Add a custom DNS record to mydomainname.com:” right?

Perhaps this will be better than creating a sub-domain in the Domains part of the panel, and then changing the DNS details to that of my server running at home?

I don’t know which is better. I was thinking that by not adding it as a sub-domain in the panel, anyone trying to call me on voip.mydomainname.com won’t first have the call protocol forwards to port 80 and instead it will all just be redirected to my home server.

Help greatly appreciated.


#2

Use Custom DNS and add your IP-number in the A-field.

For a true DH Subdomain, the A-field is set by DH to some server they choose.


#3

Thanks erikjacobsen!

I spoke to Dreamhost too to check on something else and their reply was useful.

Both will do the same thing. If I create a Custom A record on domain.com with the name home (home.domain.com) it will forward to my home server using the given IP address.

If I create a full sub-domain (home.domain.com), and change the DNS record to the given IP address, that will forward onto my home server BUT, I can still add additional services, such as mail, Jabber etc…

If I use the first option, a Custom A record, I can’t use mail or other services for the domain home.domain.com

Thanks for your reply, all closed.


#4

For a full subdomain I thought the A-record would fall under “Non-editable DreamHost DNS records”

For the benefit of other users, could you tell us if you made it work with a full subdomain?


#5

No, you can edit the DNS records for the sub-domain.

I got this to work fine.

You must remove hosting for the sub-domain (or just not give it hosting in the first place).

I’m now forwarding voip.mydomain.com to my home server as well as using hello@voip.mydomain.com all perfectly.


#6

Thank you - I didn’t think of that!