Custom CPAN? Need to update DBD::mysql


#1

I play counter-strike:source and if you do too, you probably know about psychostats.

Psychostats is a script that logs into the server, retrieves log files, and turns them into a website full of player statistics for the server.

Psychostats does this by running a perl script on a cron job every .

My Problem :

I get the error, “> DBD::mysql v3.0008 or newer (currently installed: 2.9006)”

I’ve contacted dreamhost support about this and they can’t walk me through any of it, they have only been able to give me hints like a custom CPAN installation.

I’m not a linux freak, I know how to get around with basic commands and use vim. Other than that, I’m clueless.

What I need is a way to update this DBD::mysql module to a higher version so that I can run this perl script to update the stats.

I hope someone can help me.

Thanks.

  • dave

#2

or does anyone know the location of the current version of perl on the dreamhost servers?


#3

$ which perl

<3 css btw

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#4

well so far i’ve followed this >> http://wiki.dreamhost.com/CPAN

But it’s still not working i’m not sure what to do