Current Rails Gem Version? {Solved}

software development

#1

Update:
[color=#C71585]Installed 2.2.2 in [/color]{RAILS_ROOT}/vendor/gems/rails-2.2.2.
[color=#FF1493]Included the following in environment.rb:[/color]
ENV[‘GEM_PATH’] = File.expand_path(’{RAILS_ROOT}/vendor/gems/rails-2.2.2’) + ‘:/usr/lib/ruby/gems/1.8’

====================================================
When I loaded my Ruby On Rails website, back in 2009, the current rails gem version was 2.2.2.

Today my site won’t load on DreamHost saying 2.2.2 is missing.

How do I (step by step) determine the current version DreamHost is using for Rails Gem so that I can update my config file?

I say step by step as I am not a seasoned Ruby On Rails developer and most admin tasks are not intuitive for me.

TIA for any help you can provide.
[hr]
When I log in and enter a command

gem list

I get this:
rails (3.0.3, 2.3.8, 2.3.5, 2.3.4, 2.3.3, 2.2.2, 2.1.2, 2.1.1, 2.1.0, 2.0.5, 2.0.2)

I’ve read that dream host keeps the last three versions which would imply that 3.0.3, 2.3.8 and 2.3.5 should work if my environment.rb file contained

RAILS_GEM_VERSION = ‘3.0.3’ unless defined? RAILS_GEM_VERSION
or
RAILS_GEM_VERSION = ‘2.3.8’ unless defined? RAILS_GEM_VERSION
or
RAILS_GEM_VERSION = ‘2.3.5’ unless defined? RAILS_GEM_VERSION

However, all three fail.