Css?


#1

hi,
can anyone tell me what i need to do to get rid of the whitish lines that appear in the left hand menu?

my site is http://www.millenniummortgageinc.net

everything looked fine until i decided that i did not like the color used in the left hand menu, so i changed it to b0c4de. well, i edited the .css and, yes, the color did change, BUT, now there are some white lines showing up that i dont want there.

could anyone give me an idea of how to get rid of these lines?

thank you,
chunky

Chunky


#2

Internet Explorer doesn’t support child selectors in CSS.

[code]/*********** #navBar link styles ***********/

#navBar ul a:link, #navBar ul a:visited {display: block;}
#navBar ul {list-style: none; margin: 0; padding: 0;}

/* hack to fix IE/Win’s broken rendering of block-level anchors in lists */
#navBar li {border-bottom: 1px solid #EEE;}

/* fix for browsers that don’t need the hack */
html>body #navBar li {border-bottom: none;}[/code]

:cool: Perl / MySQL / HTML+CSS


#3

err ahh…

what did you send me…is this some way around the “child selectors?”

sorry, i am so ignorant.
chunky

Chunky


#4

There appears to be a flawed hack in the CSS:

/* hack to fix IE/Win's broken rendering of block-level anchors in lists */ #navBar li {border-bottom: 1px solid #EEE;}Try commenting this out (move the */ to encompass the rule as well).


Simon Jessey
Keystone Websites | si-blog


#5

[quote]There appears to be a flawed hack in the CSS:

/* hack to fix IE/Win’s broken rendering of block-level anchors in lists */
#navBar li {border-bottom: 1px solid #EEE;}

Try commenting this out (move the */ to encompass the rule as well).[/quote]
It’s not necessarily a flawed hack. The OP changed the background color and neglected to make sure he updated the other colors to match. See the #EEE? That is what is causing the white lines. He should have changed that to the same color as his new background color, and problem resolved.

OP’s next problem is that “small peach” icons in the menu were meant to be displayed against a white background, too. They don’t look good against the new background color because of the white fringe.

:cool: Perl / MySQL / HTML+CSS


#6

well thanks. i changed to jive with background color and that is all that i did. well, that worked but my spacing has changed. i did not do anything else but change:

#navBar li {border-bottom: 1px solid #EEE;}
to
#navBar li {border-bottom: 1px solid #boc4de;}

any ideas. thank you sooooo much for your responses.
again website is http://www.loansatlanta.com

to get an idea of the before, i have the same website but with a different header at http://www.millenniummortgageinc.net

thanks!!

Chunky


#7

[quote]#navBar li {border-bottom: 1px solid #EEE;}
to
#navBar li {border-bottom: 1px solid #boc4de;}[/quote]
Thanks for the laugh =) The letter o is not a hexadecimal digit.

:cool: Perl / MySQL / HTML+CSS


#8

i am sure my skills could provide you a laugh a minute.
thank you!!!

Chunky