CrossFTP

dreamobjects

#1

I can connect to DH DreamObjects just fine with CyberDuck.

I want to try CrossFTP now and cannot get a connection…

Using Host objects.dreamhost.com – s3
protocol S3/HTTPS
Port 443

proper keys

any ideas???

THANKS


#2

Those settings look right to me. What is the error you are getting?

This article has some screenshots that could help you double-check settings.


#3

Can confirm. This is the error message I am receiving:

CrossFTP 1.97.6
Ubuntu 14.04


#4

The screenshot shows Port 80. That doesn’t seem right to me, but that’s what it says.


#5

Agreed. I tried port 443, but got this error message:

and this popup error message: http://i.imgur.com/DfgBhA9.png


#6

I agree you won’t want port 80, but it should technically work as well.

I downloaded the latest crossftp, and when setting up the connection I chose “S3/https” and filled out the settings, and it connected fine. In the drop down, at the bottom, was also a “DreamObjects” entry, that when selected asks for the access and secret keys, then dumps the info into “S3/https” for you. That connected normal also. I lastly tried leaving it as “S3” and port 80, and it connected also. Here is a screenshot of what my settings looked like:

https://objects.dreamhost.com/publictest/s3-https-test.png


#7

I missed this the first time around (chose plain S3). Now it works with port 443.

Is there a recommended port, other than 443?


#8

Nope, 443 is what you want for security and is what is expected. Glad to hear it works now with that port.