Crontab


#1

Hi I have a script that requires crontab to be set up the script instructions are

http://www.expertzzz.com/Wiki/home/103/

I am using putty I enter the path to the file and get this error

/usr/local/bin/php":0: bad minute
errors in crontab file, can’t install.

This is the [color=#0000CC]periodic.file [/color] I am trying to install

[color=#CC0000] which phpMAILTO=rob@staticpresence.com

0 0* * * /usr/local/bin/php -q

/home/kinkynik/www.staticpresence.com/aaa/periodic/cmd.php

*/10 * * * * /usr/local/bin/php -q

/home/kinkynik/www.staticpresence.com/aaa/periodic/notifies.php
[/color]

Thanks in advance for any help


#2

crontab -e
to edit the crontab file
You can find some info on the wiki…I suggest to set VIM as editor…

Cupons:[color=#0000CC]MAO_HALFPRICE[/color] : pay only half of the price (L1 plans only) MAO97 get 97$ back


#3

Could use a space between 0 and *. Order looks messed up. Time and command need to be on one line:

MAILTO=rob@staticpresence.com
0 0 * * * /usr/local/bin/php -q /home/kinkynik/www.staticpresence.com/aaa/periodic/cmd.php
*/10 * * * * /usr/local/bin/php -q /home/kinkynik/www.staticpresence.com/aaa/periodic/notifies.php


#4

I should stop to reply without reading messages first :slight_smile:

Cupons:[color=#0000CC]MAO_HALFPRICE[/color] : pay only half of the price (L1 plans only) MAO97 get 97$ back


#5

update

ok tried this

[color=#CC0000]MAILTO=admin@nostringsfunuk.com
0 0 * * * /usr/local/bin/php -q /home/kinkynik/nostringsfunuk.com/sexcontacts/periodic/cmd.php
*/10 * * * * /usr/local/bin/php -q /home/kinkynik/nostringsfunuk.com/sexcontacts/periodic/notifies.php [/color]

but now get the error

[color=#00CC00]crontab: installing new crontab
"/tmp/crontab.Sviz1q/crontab":1: bad day-of-week
errors in crontab file, can’t install. [/color]

soz im still a newbie to this side of things… What is vim?

ty rob


#6

I had the same problem before.

If you are using putty in windows platform, the script may automatically go to next line although you did not press enter key. Just use the backspace to make the script is in one line.

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color]. Sign Up NOW


#7

Ok tried that and it seem to be working now…

Thanks nathan


#8

welcome.

I struggled the whole afternoon to solve the problem. I’m glad it solves your problem too. :wink:

Save [color=#CC0000]$97[/color] (max discount) with [color=#CC0000]97CRAZY[/color] Save [color=#CC0000]$82[/color] and lifetime domain with [color=#CC0000]82CRAZY[/color]. Sign Up NOW


#9

I had the same issue with it wrapping to next line. It tells in the wiki how to disable that, but I don’t think it took.
Silk

My website