Crontab & Permission denied

software development

#1

Hi

hopefully some one can help a me, I’m pretty well a newbie, I’ve just opened an account here and am having a problem creating a cron job. Before I post a support request thought i’d run it be here first in case I’m being a bit thick :slight_smile:

I created a file cronfile.txt and FTP’d into mydomain.com folder

I’ve logged in on my domain via ssh :-

ssh myusername@mydomain.com

entered my password, all good logged in

At the command line I entered :-

crontab cronfile.txt

but I get return :-

[popcorn]$ crontab cronfile.txt
crontabs/tmp.9gvxrb: Permission denied

If I crontab -l I get :-

crontabs/myusername: Permission denied

Am I missing something obvious, I’m a complete newbie but have followed wiki and other texts I thought the above should have worked or do I need to request crontabs from dreamhost?

Many thanks in advance

rob


#2

Hi

thanks for the pointer. I’d tried it before, here what I tried again!

[popcorn]$ dir
Maildir id_rsa.pub logs mydomain.com
[popcorn]$ cd mydomain.com
[popcorn]$ dir
cronfile.txt
[popcorn]$ crontab cronfile.txt
crontabs/tmp.RfPPaQ: Permission denied
[popcorn]$

This is stumping me. I’ve read a few diffrent wiki pages and my account dir just dosnt add up to whats in the wiki.

Many thanks

rob


#3

Hi BobS

many thanks for taking the time to help, I’ve just posted a support request.

cheers

rob