Crontab mkstemp: Permission denied

Hi,

As of today, I can no longer access crontab. That is to say if I type:

crontab -e

I get the following “Permission Denied” messages:

/var/spool/cron/: mkstemp: Permission denied
crontabs/fredy/: fdopen: Permission denied fredy@ps492155:~$

Before this all worked perfectly fine. I haven’t changed anyting so I have no idea why I am now seeing these Permission denied messages?

Any help would be much appreciated.

Hi Guassian,

Thanks for reaching out to DreamHost Support. We attempted to replicate this error and were unable to. We sent you an email regarding this. If you’re still experiencing problems please respond to the email and we will help resolve this issue asap.

Thanks!

Amy

Hi Amy,

Thank you for your assistance here.

The error persisted for at least 5 days however I just checked and I can confirm that it has indeed disappeared. Everything appears to be working fine now. Thanks again.

Gaussian.

This has just started happening to me. I had a crontab and, for no apparent reason, it disappeared. Now, when I try to create one, I get:

$ crontab -e
It looks like you don't have a MAILTO line in your crontab file
For performance reasons we ask that you specify an address where
cronjob output will be delivered.  If you do not wish to receive
cronjob output, simply press enter and cronjob output will not be
mailed to you.

For more information regarding this, please visit:
https://help.dreamhost.com/hc/en-us/articles/215088608

Where would you like cronjob output delivered? (leave blank to disable)
: [...]

cronjob output will be emailed to [...]
confirm? (y/N): y
/var/spool/cron/: mkstemp: Permission denied
no crontab for [...] - using an empty one
crontab: installing new crontab
/var/spool/cron/: mkstemp: Permission denied
crontab: edits left in /tmp/crontab.m8PgNB/crontab

$ crontab -e
It looks like you don't have a MAILTO line in your crontab file
For performance reasons we ask that you specify an address where
cronjob output will be delivered.  If you do not wish to receive
cronjob output, simply press enter and cronjob output will not be
mailed to you.

For more information regarding this, please visit:
https://help.dreamhost.com/hc/en-us/articles/215088608

Where would you like cronjob output delivered? (leave blank to disable)
:

By the way, I note:

$ ls -ld /var/spool/cron/crontabs
drwxr-xr-x 3 root root 4096 May 15  2019 /var/spool/cron/crontabs

Should the group ownership be crontab and/or the permissions set so that the group crontab can write to it?

I was able to use the DreamHost control panel to create a new crontab to replace the one DreamHost nuked.