Creating mirrored test site - database question


#1

Hi - I am working to transfer a site to dreamhost from daily razor. Thus far, I have:

  1. 1-click installed wordpress
  2. FTP’d the wordpress files over
  3. Setup a mirrored domain (http://slowfoodchicago.dreamhosters.com) and a mysql database for that mirrored domain
  4. Imported SQL file of the site i want to transfer

I have been following the instructions here, but now I am stuck on the ‘Test installation’ step.

When I go to my subdomain, I receive the WP install page: http://slowfoodchicago.dreamhosters.com/wp-admin/install.php
Does that mean something is not appropriately setup?

Also, I don’t fully understand these steps: “Once you’ve logged into the phpMyAdmin interface, select the appropriate database, then “browse” the tables and edit their values to replace instances of “yourdomain.net” with “yourdomain.dreamhosters.com”.” What am I changing within the database? Do I have to do this for the test installation?

Thanks!
Ryan


#2

for now, just go complete the form on that wordpress page. It’s the last step of wordpress setup.

Since you have posted the link go do it now before someone else does…
[hr]
Also change the deafult of Admin to something like Your name… don’t use admin, it’s too easy to hack


#3

Ah, yes thank you. Setup.

I come to a blank page now


#4

Ok now do the database edits, so you can see your wordpress install. you reach phpmyadmin from the mySQL may in the dreamhost panel. The values your looking for are in the options table which will have a random prefix before _options. Once you do that you will be able to see your wordpress install.


#5

Thanks LakeRat. I am able to browse the WP_options table. I don’t see anything with a “_options” element to it, besides the table name wp_options of course. The table itself has a number of values in each of the following columns:

option_id	blog_id	option_name	option_value	autoload 

What am I changing? Thank you again!


#6

It sounds like your on the structure tab. Click the browse tab in the top left. The 3rd or so item down should be “siteurl” click the pencil on the left end of the line to edit it.


#7

Got it, changed the value for site url to the new URL from the old one. Now what?


#8

And we are still seeing a white screen I see. I note now that you imported a database, but you did still get the install screen.

I think what’s happening here is the dreamhost one click installer creates a random prefix to make worpress harder to hack into. You mentioned above that your prefix was WP_ , so in that case go to your ftp naviagate to the folder that has wp config, open it for editing and scroll down until you find the $table_prefix entry and change the value to ‘WP_’


#9

Did as suggested and still white screen.

I was able to login to the wp-admin screen but i see this on the dashboard:
ERROR: The themes directory is either empty or doesn’t exist. Please check your installation.

What causes this?

Also, I see all these wp_hgzh36_… tables. Are they artifacts from the one-click installation?


#10

As you request a dreamhost once-click there is a box called “deluxe install” that is checked by default? Did you leave it checked or uncheck it? If left checked there should definitely be some themes, so the folder shouldn’t be empty. Also I would expect if the box was unchecked there should at least be one theme, and not be empty or missing. You can see manually what’s there by navigating in your ftp to /wp-content/themes/ . In any case this probable is point out that the theme called for in your database is in fact not there. Since you can get into wp-admin this shouldn’t be too difficult to fix. If it’s a custom theme, you may need to bring it over from your old install via ftp, if it was downloaded from wordpress.org just go fetch it again via wp-admin.

Yes the wp_hgzh36_ are an artifact at this point and can be deleted. The story is after a a huge rash of hacked WP sites early this year, one of the things dreamhost did to stengthen it’s wordpress installs was to make the database table names unknown to hackers by making the prefix random. The wiki instructions you have been following apparently haven’t yet been amended to reset the table prefix. I wonder tho, if renaming the database tables to include the random prefix isn’t the better option.


#11

LakeRat, the table prefix has always been random for as long as I can remember. That’s not a recent addition at all.


#12

On renaming the prefix, done.

On the deluxe install - no, I don’t believe that I selected that. I brought over the entire contents of the DEV directory from the site that I was working on (which is the site I am looking to transfer). When I navigate to wp-content/themes, I see my theme.

The directory looks like this right now, is that right?

  • logs (blank)
  • maildir (blank)
  • slowfoodchicago.org (includes wp-admin, wp-content, wp-includes, etc.)

#13

That doesn’t look right. The Wordpress files (wp-admin/content/includes, and all the php files) belong in the domain directory, not in the root level of your FTP account.


#14

So if you did a dreamhost one click install, it should have put the files in the right place. Did you also import a set and thus have two sets? or did you move them? And it seems like if you have two sets that you did manage to change the correct wp-config when we dealt with the table prefix?


#15

What do you mean by sets?

andrewf - the wordpress files are in the domain directory, they are nested, that did not post correctly in my repsonse.

Also, to describe more symptoms, in the admin page, I see the correct theme, and even the right plugins, but I do not have the right data (posts, pages, customizations to theme etc).


#16

I’m guessing there are more domain specific references in your database that you need to find and update manually.

Your response to andrewf took care of my other questions…


#17

Do I need to edit the domain directory to slowfoodchicago.dreamhosters.com?

I will go through the database and update the instances. They only occur in the posts table from what I can tell