Creating databaes

I am unable to create MySQL databases. Some background:

-My (sub)account was created by the owner of this account, he believes he has given me every possible permission.

-The blue ‘Create a new MySQL database’ box, as seen on the page
is not visible when go to the page in the Panel - Goodies - Manage MySQL. It is visible for the main account owner. I can, however, create new hostnames.

-I can log in with PHPMyAdmim, and it shows that I have permission to create databases. However, if I try to do so, it gives the following error:
ERROR 1044 (42000): Access denied for user ‘my_user’@‘’ to database ‘db1’

-I created a new hostname with nothing on it, waited for it to become active, logged onto my shell account, logged into that host via the mysql command line utility, and tried to create the database there. Same error message.

Question 1: Is it even possible for me to create databases, or must I bug the account owner (which he does NOT appreciate) every time a database needs to be created?

Question 2: If I can create databases myself, how?

Thanks in advance…

To answer Question #1: No. You have to create those through the panel unfortunately :confused:

As for Question #2, I’m not entirely positive, but if the “owner” has given you full permissions, then you should have exactly the same permissions as them. If not, then they didn’t give you “full” permissions and need either create the database for you, or go back and change your permissions.
(I should add - this isn’t something I’ve ever personally done before, so I’m not sure how to go about all of that myself. But I’m sure someone here will know :wink: )

That all depends on what “Account Privileges” the “master” account user assigned to your user.

As Mousee indicated, you can only create a database from the Control Panel–>Goodies–>Manage MySQL screens; PhpMyAdmin, shell command line instructions, or program/script generated queries will not work for database creation on DH (there are also a few other commands that will not work, as are documented in the wiki).

The first thing I suggest is to confirm with the master account user that he has given you permission to create new databases. If not, he needs to do that for you to be able to create them, and then you will have to use the Control Panel.


Thanks for your quick response.

I know there are things that I simply don’t see in the panel which the account owner does, so it’s hard/impossible for me to tell the account owner what to do to give me full permissions. Like I said, he says he thought he had, but it looks from what you say like he must have missed something.

Can you tell us exactly what persmission he must give me (and how to do so in the panel) so that when I go to Goodies -> Manage MySQL I will see the little blue ‘Create Database’ form at the top of the page? I currently see a page which, as far as I can figure out, seems to be identical to what he sees, but no ‘Create Database’ form.

Thanks again,

Sorry this isn’t exactly the greatest image in the world… but it shows you which option needs to be set at least:

This sucks for the owner of the account, because it opens up ALL of the other databases to you. But it’s the only way that you’ll be allowed to actually create your own database(s).


What he needs to do is to go to the Control Panel --> Billing --> Account Privileges Screen and click the little “wrench” icon next to any of the privileges he has assigned to your user.

Under the “databases” section he should select the box that says “ALL current and future databases?”. This will enable you to create new databases, and hosts, but it will also allow you access to all existing databases, not just those you have created.

Unfortunately, the controls cannot be set up to allow you to create new database and retain access only to those databases. For this reason, in situation like you describe, I always create the databases for my subusers and then assign them access to only those databases.


edit: Ooops! Sorry for the “double answer” - I got distracted while typing this reply - what Mousee said! :wink: