Could anyone help me with these paths please?


#1

Hiya, can anyone tell me what i should change the following three paths to please?

[color=#0000CC]## (1) Specify the location of your webbbs_settings.pl script:

require “/usr/foo/cgi-bin/webbbs_settings.pl”;

(2) Locate the files and directories unique to this forum:

$dir = “/usr/foo/forum”;
$cgiurl = “http://www.foo.com/forum/webbbs_config.pl”;[/color]

I read somewhere about a file i could create to tell me a ‘full path’ and this (in red) is the result of the test file (which is located in the same directory id like to install the script to). I hope it helps to fill in the blanks that i forgot to include.

[color=#CC0000]The full path to THIS file is /home/.canicula/bbh/bishbash.com/bbs/test.php[/color]

thankyo for your time


#2

Assuming that the files “webbbs_settings.pl” and “webbbs_config.pl” are in the same directory, that is the /bbs/ directory, paths be so:

(1)
require “/home/.canicula/bbh/bishbash.com/bbs/webbbs_settings.pl”;

(2)
$dir = “/home/.canicula/bbh/bishbash.com/bbs/”;
$cgiurl = “http://www.bishbash.com/bbs/webbbs_config.pl”;

If those files are not in the same directory then adjust your paths accordingly, which I guess is what you’re asking about here, so, good luck! :slight_smile:

[color=#0000CC]jason[/color]


#3

ive set those up like that now and made sure that every file is set to 777 permissions (probably not the safest but oh well) but i still get the “Internal Server Error… The server encountered an internal error or misconfiguration and was unable to complete your request” error.

Any idea what this means or how i can rectify it? Ive heard about looking at logs but ive no idea how to do that.

thanks


#4

check your shebang line at the beginning of your Perl script(s) and make sure it matches one of these:

/usr/bin/perl
/usr/local/bin/perl

[color=#0000CC]jason[/color]


#5

hiya. i think i understand what you mean so i searched all the files in the directory and the blahblahblah_config.pl file starts off with the line “#!/usr/local/bin/perl”

is this what you mean?


#6

yep, that’s correct, as it should be, no need to change that

check your error logs in your user directory (just outside your web root) and see if there’s anything in there for clues

[color=#0000CC]jason[/color]


#7

ermm heres the error log thing,

[Wed Jul 6 14:33:30 2005] [error] [client 81.157.191.195] Premature end of script headers: /home/bbh/bishbash.com/bbs/webbbs_config.pl
[Wed Jul 6 14:33:30 2005] [error] [client 81.157.191.195] File does not exist: /home/bbh/bishbash.com/internal_error.html

i get the same error and error log message when i try to run perldiver which i am told needs no setup at all.

sorry to be annoying


#8

have a look at this section of Apache’s documentation and see if any of that sounds plausible. If you get to the end and the suexec mention before finding the problem, you might want to contact support from the web panel, be sure to bring the error messages into the support request, maybe reference this thread as well.

Good luck

[color=#0000CC]jason[/color]


#9

thanks i’ll have a look


#10

Sounds lilke problems I have had in the past, until I realized that Dreamhost’s configuration does not like executable files with 777 permissions. In each case, for me, changing the permissions on all executables (.cgi, .pl, etc) from 777 to 755, irrespective of the script author/provider’s instructions, has solved the “Internal Server Error” issue. This assumes that the user who uploaded the file is the user who owns the directory (which should be the normal default for Dreamhost shared hosting accounts).

Of course, you will still have to properly define the paths in the indicated files, but I will almost guarantee you that the script(s) will not run under Dreamhost with permissions set to 777.

Just my 2 cents worth '-) Good Luck!

rlparker