Correct SSI directives generate error message


#1

Hi, there. I’ve got this problem with http://www.econguru.com . The same SSI files fail to work correctly on one of my domains here hosted on mariposa.dreamhost.com, which run smoothly on my local Apache server. Every SSI directive just gives out an error message as [an error occurred while processing this directive]. I assuare you they are correct SSI directives, but then why is this happening? Wherever I put these SSI files in the econguru.com directory, they just don’t make it right. And, I write a very simple SSI file containing only < ! - - # echo var=“DATE_LOCAL” - - > under another one of my domains here at DH, kavoir.com, while working perfectly right locally, it makes me upset yet again. You can check it at http://kavoir.com/test.shtml

Anybody ever encountered this problem before, what can I do to make them display the right things? You can check the

Thanks a million!


#2

Check your .htaccess file, and if you don’t have directives set to exclude SSI, contact support

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#3

Use this entry:

!--#echo var="DATE_LOCAL" -- Note there are no spaces as you have it < ! - - # echo var=“DATE_LOCAL” - - >.
unless you have inserted them for this forum. The hash character needs to be next to the echo command.

(Replace the less-than and greater-tags around my line again without spaces)


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#4

thank you Atropos7, but if there’s any directives to exclude SSI, there would be no error messages at all, or would there?


#5

“The hash character needs to be next to the echo command.”

This proves to be a life saver, thanx Norm!

I did separate the < ! - - for the sake of the forum, but what I didn’t know is # should be immediately before the instruction. Funny it is, a space between # and the instruction is ok in my local Apache environment…wondering why…

thanx again, Norm! And Atropos!


#6

Strangely enough on some versions of Apache there had to a space between the hash and command. If I want to quickly disable a SSI I just inserted a space.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#7

And the next obvious attempt at helping: have you checked the error log? Have you checked the owner of the file?

:cool: [color=#6600CC]Atropos[/color] | openvein.org