Correct settings for Dreamhost + Google Apps + Subdomains


#1

I’ve struggled getting a domain to work with Google services. I want

Either of these will work, but not both, and right now I’ve managed to make neither one work. I had example.com leading to the Google Apps front page, then I tried to add a CNAME record for ‘sub’ so that the subdomain would go to Blogger. That worked, but it caused the primary domain to stop working (and, importantly, the email addresses on the primary domain).

I removed the CNAME record and the subdomain stopped working (good) but the primary domain still doesn’t work. I edited the site in the control panel to be Google Hosted and that hasn’t seemed to help (it’s been a half hour since making that change).

Before going too deep into it, can anyone proffer the way it SHOULD work?


#2

Well, I have to say I’m feeling both baffled and embarrassed. Dreamhost support told me they didn’t know what was wrong with my primary domain, or my email address, but that I’d done the right thing with the CNAME record. Something else messed up my domain, and I don’t know what, but Support told me what to do to fix it.

I will summarize to save someone else the same embarrassment:

To use your primary domain (example.com, www.example.com) with Google Apps, you “Fully Host” your domain with Dreamhost. To do that, go to the control panel and ‘Edit’ your domain. The first option is ‘Fully Hosted’ so fill out the options in that box and click the ‘Change Settings’ button/link. If you want to use Gmail-style email with your Apps domain, which you probably do, then make sure to check that checkbox. You do NOT need to check the ‘Google Apps’ checkbox if you don’t want calendar and docs – which might be slightly confusing to people, because you are using Google Apps, but not that kind of Google Apps.

After that, you set up your domain at Google. I had already done that and won’t detail it here.

Then, if you want to set up a Blogger blog as a subdomain, that is easy. Go back to the control panel and click ‘DNS’ under the desired domain. To be clear, do NOT set up a subdomain, edit the DNS for the primary domain. That means, if you want blog.example.com, do NOT create the blog.example.com domain, rather click ‘DNS’ under ‘example.com’. Then, add a CNAME record where the ‘Name’ is “blog” (or whatever you want) and the ‘value’ is “ghs.google.com”.

Other directions on the internet will tell you to set up some A records. Do not do this. I think that’s if you want the Blogger blog on your primary domain.

Variations of these directions can be found all over the place. Now here is one more. The good people at Dreamhost Support have my apologies for bothering them with a problem I probably created for myself, and on Labor Day no less.

So what was my problem? I don’t know. I thought it was the CNAME record, but apparently it was not. To the best of my knowledge, my website is configured the same now as this morning when I couldn’t get to my site or receive email.